Last modified: 2009-03-27 22:19:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17161 - Inputbox search forms do "go" when hitting Enter in Internet Explorer
Inputbox search forms do "go" when hitting Enter in Internet Explorer
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
InputBox (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Aaron Schulz
http://en.wikipedia.org/wiki/Wikipedi...
:
Depends on:
Blocks: 640
  Show dependency treegraph
 
Reported: 2009-01-26 17:44 UTC by Brion Vibber
Modified: 2009-03-27 22:19 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Brion Vibber 2009-01-26 17:44:14 UTC
Same issue as bug 13778 -- the "fulltext" parameter in the default submit button doesn't get submitted by Internet Explorer if you hit enter in a text field.

As a result, fulltext searches from a form end up performing a "go" exact-match search on submission, which isn't what was intended and sometimes gives surprising results.

Forms intended to be fulltext-only need to include a hidden field providing the "fulltext" parameter so it will actually get sent.
Comment 1 Aaron Schulz 2009-02-26 20:16:05 UTC
Fixed in r47840
Comment 2 Umherirrender 2009-03-27 22:19:22 UTC
Adding IE tracking bug.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links