Last modified: 2009-03-17 14:04:33 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16856 - Add 'suppressredirect' group permission for sysops on de.wp
Add 'suppressredirect' group permission for sysops on de.wp
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
http://de.wikipedia.org/w/index.php?t...
: shell
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-01 12:31 UTC by Raimond Spekking
Modified: 2009-03-17 14:04 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Raimond Spekking 2009-01-01 12:31:10 UTC
Per community consensus please add the following group permission for dewiki:

$wgGroupPermissions['sysop'  ]['suppressredirect'] = true;
Comment 1 P.Copp 2009-01-02 23:42:12 UTC

*** This bug has been marked as a duplicate of bug 14998 ***
Comment 2 Mike.lifeguard 2009-01-02 23:44:54 UTC
This isn't a dupe. This is for dewiki, where there is consensus to do this. The other bug is for doing to by default in MediaWiki and on all WMF sites.
Comment 3 P.Copp 2009-01-03 00:15:43 UTC
Well, yes.. But does it make sense to fix it for one wiki only, when it should rather be done for all wikis at once?
Comment 4 Church of emacs 2009-01-12 21:22:33 UTC
@P.Copp: Well, this is not only a technical issue, but also a question of what the community wants. And I can't see a clear consensus that rollbackers are granted suppressredirect right - so that has to be decided first. On the other hand, here we already have a consensus here, so changing this userright is much less controversial.
Comment 5 P.Copp 2009-01-12 21:45:00 UTC
You will certainly be having a hard time finding a wiki, where there's no consensus to give that right to _sysops_. So I can't see a reason for giving the right to sysops on dewiki, while leaving it diabled on other wikis.
Comment 6 Tim Starling 2009-02-02 01:34:02 UTC
Done for dewiki. Have a vote on meta or something if you want it enabled on the other wikis.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links