Last modified: 2008-12-17 15:38:19 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16527 - list=watchlist/recentchanges lacks a show/hide self option
list=watchlist/recentchanges lacks a show/hide self option
Status: RESOLVED DUPLICATE of bug 14200
Product: MediaWiki
Classification: Unclassified
API (Other open bugs)
1.14.x
All All
: Normal enhancement (vote)
: ---
Assigned To: Roan Kattouw
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 07:06 UTC by MER-C
Modified: 2008-12-17 15:38 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Half of it, add self/!self parameters to ApiQueryWatchlist (1.37 KB, patch)
2008-12-02 12:33 UTC, Chad H.
Details

Description MER-C 2008-12-02 07:06:36 UTC
To be consistent with the GUI, the two above modules should have a show/hide own edits option under ucshow.
Comment 1 Chad H. 2008-12-02 12:33:59 UTC
Created attachment 5551 [details]
Half of it, add self/!self parameters to ApiQueryWatchlist

This should handle half of the bug, adding it to ApiQueryWatchlist. Wasn't as sure with ApiQueryRecentchanges.
Comment 2 Roan Kattouw 2008-12-02 12:36:20 UTC
Comment on attachment 5551 [details]
Half of it, add self/!self parameters to ApiQueryWatchlist

I'd rather implement this in a more generic way with {rc,wl}{user,excludeuser} params, like prop=revisions does.
Comment 3 Roan Kattouw 2008-12-17 14:51:06 UTC
Fixed in r44716.
Comment 4 Roan Kattouw 2008-12-17 15:38:19 UTC
(In reply to comment #3)
> Fixed in r44716.
> 

Whoops, just discovered this is really a dupe of bug 14200, which can't be fixed until the schema change is done. Reverted in r44718 and attached patch to bug 14200.

*** This bug has been marked as a duplicate of bug 14200 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links