Last modified: 2010-05-15 16:03:47 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16502 - External link icons are not displayed for RTL in Monobook
External link icons are not displayed for RTL in Monobook
Status: RESOLVED DUPLICATE of bug 1061
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
1.13.x
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
http://wiki.chawg.org
: patch
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2008-11-30 01:06 UTC by Sia
Modified: 2010-05-15 16:03 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sia 2008-11-30 01:06:18 UTC
hi,	
if I use other language instead of English, for example using Kurdish (Sorani) or Arabic with RTL direction. The images in default skin (Monobook) are not displayed.
I've tried the following code.

 [http://mediawiki.org MediaWiki]
 [mailto:info@example.org email me]

the links worked fine, but don't display the  external.png & mail_icon.gif beside the Links.

best regards
Comment 1 Brion Vibber 2008-11-30 01:08:43 UTC

*** This bug has been marked as a duplicate of bug 3956 ***
Comment 2 Sia 2008-11-30 20:41:39 UTC
please dont add my bug to another thread.
that is not correct.
my bug have nothing to do with bug 3956 , nothing
Comment 3 Aryeh Gregor (not reading bugmail, please e-mail directly) 2008-11-30 20:53:56 UTC
Let's keep bug 3956 restricted to the user icon only, and keep this bug for the external link icons.  They seem to be entirely different problems.  I can confirm that the external link icons simply don't exist on RTL: e.g., look at

http://he.wikipedia.org/wiki/User:Simetrical/bug_16502

and note that there are no icons.  This should be some straightforward CSS to fix, although it will probably result in code duplication.  The culpable code is in skins/monobook/rtl.css:

/* Fix link icons */
.external {
	padding: 0 !important;
	background: none !important;
}

"Fix" in this case means just get rid of the icons, instead of bothering to get them to display in the opposite direction.  To fix this, we'd want to copy over all the link icon code, with padding and background direction changed.  We could omit the actual URLs and stuff and just use background-position if we liked, but we'd still have to re-specify the actual padding values, since it's different for different icons.

The only reason I'd hesitate to do this is because they may have been dropped because some browsers choke on them for some reason, due to some kind of RTL-related bug.  This would require testing in all major browsers to avoid regressions in appearance for RTL users.
Comment 4 Sia 2008-11-30 21:02:52 UTC
thanks 
i fix it, just remove 

<pre>
 /* Fix link icons */
.external {
	padding: 0 !important;
	background: none !important;
}
</pre>

in rtl.css and worked fine.

best regards
Comment 5 Aryeh Gregor (not reading bugmail, please e-mail directly) 2008-11-30 21:03:34 UTC
The bug is not fixed until a fix is checked into Subversion.
Comment 6 Siebrand Mazeland 2008-12-23 17:02:54 UTC
* update component
* assigning to Rotem, as he is probably able to assess if the fix suggested in comment 4 is proper, and he is able to commit it
* +patch
Comment 7 Brion Vibber 2008-12-23 17:04:42 UTC
They're not shown for RTL due to past browser bugs causing broken display when they were on. It needs to be carefully tested before just slapping it back in.
Comment 8 Brion Vibber 2008-12-23 17:05:28 UTC
Is this bug 1061?
Comment 9 Danny B. 2009-01-06 20:26:40 UTC
(In reply to comment #8)
> Is this bug 1061?

Indeed. The problem is for all links with CSS added icons regardless their function.

*** This bug has been marked as a duplicate of bug 1061 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links