Last modified: 2011-04-06 22:22:12 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16145 - Hide redirects from search suggestions (mwsuggest.js)
Hide redirects from search suggestions (mwsuggest.js)
Status: RESOLVED WONTFIX
Product: MediaWiki
Classification: Unclassified
Search (Other open bugs)
1.18.x
All All
: Normal minor with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Wikipedi...
:
: 18212 (view as bug list)
Depends on:
Blocks: javascript
  Show dependency treegraph
 
Reported: 2008-10-27 12:12 UTC by en:Fl
Modified: 2011-04-06 22:22 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
proposed patch (7.91 KB, patch)
2009-03-28 16:04 UTC, Ahmad Sherif
Details

Description en:Fl 2008-10-27 12:12:02 UTC
As described at http://en.wikipedia.org/wiki/Wikipedia:Village_pump_(proposals)#Stylistic_differences, the Search suggestion box suggests both articles and their redirects, so for example, when someone starts to type Albert Einsten they get suggested "Albert Einsten" AND "Albert einsten" (which is a redirect to the latter). To quote Pwnage8:
"It's really frustrating to type something and have five similar titles that are all redirects pop up. It's just clutter."
Is this possible to fix?
Sincerely,
[[en:Foxy Loxy]]
Comment 1 Chad H. 2009-03-28 00:50:25 UTC
*** Bug 18212 has been marked as a duplicate of this bug. ***
Comment 2 Andrew Butko 2009-03-28 09:43:04 UTC
please, add checkbox to preferences, which will not show redirects in search
form suggest
Comment 3 Ahmad Sherif 2009-03-28 16:04:23 UTC
Created attachment 5974 [details]
proposed patch

This patch may help, but it needs to be reviewed by anyone from API assignees (perhaps Roan Kattouw <roan.kattouw@home.nl>).
Comment 4 Seb35 2009-08-16 11:33:46 UTC
I disagree with this bug. There are sometimes redirects which are not simply stylistic differences. For instance, on the French Wikipedia, [[:fr:Adam RA-17]] (a small airplane without its own article) redirects to [[:fr:Roger Adam]] (its constructor). If there are no more redirects in the search box, you don't know that the article Adam RA-17 exists when you search in the search box.

I purpose to either add a checkbox in the preferences (like Andrew Butko said) either mark the redirects in the search box (e.g. in italic):
''Adam RA-17''
Adam Raga
''Adam raga''
Comment 5 Krinkle 2011-04-06 22:22:12 UTC
Redirects are indeed useful, especially for search suggestions.

If third party gadgets want a way to query the opensearch-api without redirects (ie. "Add boolean option to opensearch api to include/filter redirects"), then please open a seperate ticket for that.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links