Last modified: 2008-10-16 12:46:31 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16003 - action=sitematrix has wrong tag name
action=sitematrix has wrong tag name
Status: RESOLVED DUPLICATE of bug 14955
Product: MediaWiki
Classification: Unclassified
API (Other open bugs)
1.14.x
All All
: Normal minor (vote)
: ---
Assigned To: Roan Kattouw
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 12:38 UTC by Danny B.
Modified: 2008-10-16 12:46 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Danny B. 2008-10-16 12:38:04 UTC
api.php?action=sitematrix&format=xml shows (excerpt)

<api>
  <sitematrix count="784">
    <specials>
...
      <special url="http://beta.wikiversity.org" code="betawikiversity" />
...
    </specials>
... 
    <language code="en" name="English">
      <site>
        <site url="http://en.wikipedia.org" code="wiki" />
        <site url="http://en.wiktionary.org" code="wiktionary" />
        <site url="http://en.wikibooks.org" code="wikibooks" />
        <site url="http://en.wikinews.org" code="wikinews" />
        <site url="http://en.wikiquote.org" code="wikiquote" />
        <site url="http://en.wikisource.org" code="wikisource" />
        <site url="http://en.wikiversity.org" code="wikiversity" />
      </site>
    </language>
...
  </sitematrix>
</api>

The tag within <language> should be <sites> instead of <site> like <specials> is.
Comment 1 Chad H. 2008-10-16 12:46:31 UTC

*** This bug has been marked as a duplicate of bug 14955 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links