Last modified: 2008-12-31 22:25:02 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15770 - Cite error: Invalid <ref> tag; refs with no name must have content
Cite error: Invalid <ref> tag; refs with no name must have content
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
Cite (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/User:Tir...
:
: 11814 14190 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-30 01:29 UTC by sharon.dagan
Modified: 2008-12-31 22:25 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Proposed patch to Cite_body.php (632 bytes, patch)
2008-09-30 01:36 UTC, Ryan Schmidt
Details

Description sharon.dagan 2008-09-30 01:29:55 UTC
Hello,

Using {{#tag:ref|name=something}} to produce a <ref> doesn't work.

I think that the root cause of this problem is that Cite thinks the 
following code is invalid:

<ref name="something"></ref>

Unfortunately, this is the code that {{#tag}} produces.  

See test case here: 
http://en.wikipedia.org/wiki/User:TiredJoe
Comment 1 Ryan Schmidt 2008-09-30 01:36:31 UTC
Created attachment 5371 [details]
Proposed patch to Cite_body.php

Added a proposed patch that ''might'' fix this issue. I have not yet tested it out (will do that tomorrow if nobody else does), so I'm not sure if anything else needs changing as well
Comment 2 Steve Sanbeg 2008-10-01 19:58:23 UTC
fixed in r41512, but a little more strict than the patch; it should allow <ref name=whatever></ref>, but give the error for <ref></ref>.
Comment 3 Siebrand Mazeland 2008-10-03 23:37:33 UTC
Comment on commit, see http://www.mediawiki.org/wiki/Special:Code/MediaWiki/41512. REOPENED.
Comment 4 Niklas Laxström 2008-10-06 07:43:35 UTC
*** Bug 11814 has been marked as a duplicate of this bug. ***
Comment 5 Aryeh Gregor (not reading bugmail, please e-mail directly) 2008-10-08 00:18:19 UTC
(In reply to comment #3)
> Comment on commit, see
> http://www.mediawiki.org/wiki/Special:Code/MediaWiki/41512. REOPENED.

Was fixed in r41669, reclosing.  (Didn't affect the correctness of the fix anyway.)
Comment 6 Nicholas Wilson 2008-12-31 22:25:02 UTC
*** Bug 14190 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links