Last modified: 2008-09-29 20:30:53 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15658 - Install the StringFunctions extension on fa.wiktionary.org
Install the StringFunctions extension on fa.wiktionary.org
Status: RESOLVED DUPLICATE of bug 6455
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
unspecified
All All
: Normal enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://fa.wiktionary.org/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-20 13:52 UTC by Soroush
Modified: 2008-09-29 20:30 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Soroush 2008-09-20 13:52:17 UTC
Because it is required to process strings to have correct persian plurals in output Persian wiktionary requires to have StringFunctions extension insalled.

Me as an active user on fa.wikipedia ,whom was expected to make a required template for there, report this bug and assert its requirement there.

Thanks
Comment 1 Raimond Spekking 2008-09-20 14:01:43 UTC

*** This bug has been marked as a duplicate of bug 6455 ***
Comment 2 Platonides 2008-09-20 14:05:46 UTC
Can you explain why you need StringFunctions for plurals?

http://www.mediawiki.org/wiki/Extension:StringFunctions
Comment 3 Matin 2008-09-20 21:36:59 UTC
I am who want this function in Persian wiktionary.And I hope It will be installed urgently.

persian plural suffix is "ها".

there are 2 methods for make plural form of noun, based on the last character of noun.

if last character is one ch from below string

"بپتثجچحخسشصضطظعغفقکگلمنهیئ"

method is noun + ZWJ + suffix

(ZWJ=Zero width _joiner)

else

method is noun + suffix

Thanks
Comment 4 Huji 2008-09-27 19:44:55 UTC
StringFunctions could be helpful here, because it could give us a way to know if the last letter of the word in question is a joiner letter or not. However, StringFunctions is an overkill. If the only use of the extensions is for that, and there is no way to avoid that, I suggest we create a simple extension just for that reason. Is it good enough?
Comment 5 Huji 2008-09-27 19:47:04 UTC
Bug 13712 is much like what I said. Thanks to Niklas for pointing it out over IRC.
Comment 6 Matin 2008-09-27 22:25:10 UTC
as we know String Functions are powerful part in each language. And as one who didn't had experience in code writing in wiki, but with experience in one Language(VB.Net) I think it is unbelievable to code writing without this functions especially in wiki projects.because in wiki we had big process in text. in fact in my opinion this functions must install in all wikies as unseprated part without any voting or any discussion like this! ;)
Comment 7 Huji 2008-09-29 19:18:49 UTC
Dear Matin,

This bug is not about whether that extension should be installed everywhere or not. I'm sure there are people who disagree with you with good reasons. This bug is only seeking a solution for the problem mentioned. I have suggested a solution in the above; I've also given a link. If you think this is what is being asked, please let me know. Otherwise, please describe how that doesn't fit the needs.

Good luck,

Hojjat (aka Huji)
Comment 8 Platonides 2008-09-29 20:30:53 UTC
Matin, programming languages are different than encyclopedia writing. In particular, wikisyntax MUST NOT be turing complete (we do not just want the function to halt, but to halt in a small time). That said, StringFunctions looks quite safe, but I'm sure some users will to use it in unexpected and dirty ways, specially #pad, #replace and #explode.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links