Last modified: 2014-07-17 20:56:49 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15223 - Bad unicode rendering in digest and mail send to name
Bad unicode rendering in digest and mail send to name
Status: RESOLVED WORKSFORME
Product: Wikimedia
Classification: Unclassified
Mailing lists (Other open bugs)
unspecified
All All
: Normal normal with 4 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
https://lists.wikimedia.org/mailman/l...
:
: 16142 (view as bug list)
Depends on:
Blocks: 56295
  Show dependency treegraph
 
Reported: 2008-08-18 11:52 UTC by Jyothis Edathoot
Modified: 2014-07-17 20:56 UTC (History)
10 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jyothis Edathoot 2008-08-18 11:52:30 UTC
Hi,

The digest option converts all the Unicode chars into question marks and the To/mailto name as shown below. I have seen this as a an issue before when database and the code does not handle Unicode well.

When the To/reply-to comes in, it is supposed to show Malayalam characters instead of that gibberish. Please note that this is a problem in general, not pertaining to the Digest option.
---------To/Sendto--------
To: "&#3374, &#3378, &#3375, &#3390, &#3379, &#3330, &#3381, &#3391,
           &#3349, &#3405, &#3349, &#3391, &#3374, &#3392, &#3361, &#3391,
           &#3375, &#3370, &#3366, &#3405, &#3367, &#3364, &#3391, &#3349,
           &#3379, &#3393, &#3359, &#3398, &#3374, &#3398, &#3375, &#3391,
           &#3378, &#3391, &#3353, &#3405, &#3353, &#3405, &#3378, &#3391,
           &#3384, &#3405, &#3377, &#3405, &#3377, &#3391, &#3378, &#3399,
           &#3349, &#3405, &#3349, &#3405, &#3384, &#3405, &#3381, &#3390,
           &#3351, &#3364, &#3330, &#x0D,  Welcome to Malayalam Wikimedia
           Project's Mailing list" <wikiml-l@lists.wikimedia.org>
---------To/Sendto ends----

On the terms with digest, its rendered unreadable as seen below. 

Could you please get this fixed for us?

Thanks in advance,
Jyothis.


--------Digest begings here-------

2008/8/17 <wikiml-l-request@lists.wikimedia.org>

    Send Wikiml-l mailing list submissions to
           wikiml-l@lists.wikimedia.org

    To subscribe or unsubscribe via the World Wide Web, visit
           https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    or, via email, send a message with subject or body 'help' to
           wikiml-l-request@lists.wikimedia.org

    You can reach the person managing the list at
           wikiml-l-owner@lists.wikimedia.org

    When replying, please edit your Subject line so it is more specific
    than "Re: Contents of Wikiml-l digest..."


    Today's Topics:

      1. Re: ?????? ???????????????? ??????? (Francis Nazareth)
      2. Re: ?????? ???????????????? ??????? (Ramesh N G)


    ----------------------------------------------------------------------

    Message: 1
    Date: Sun, 17 Aug 2008 00:01:21 +0400
    From: "Francis Nazareth" <simynazareth@gmail.com>
    Subject: Re: [Wikiml-l] ?????? ???????????????? ???????
    To: "&#3374, &#3378, &#3375, &#3390, &#3379, &#3330, &#3381, &#3391,
           &#3349, &#3405, &#3349, &#3391, &#3374, &#3392, &#3361, &#3391,
           &#3375, &#3370, &#3366, &#3405, &#3367, &#3364, &#3391, &#3349,
           &#3379, &#3393, &#3359, &#3398, &#3374, &#3398, &#3375, &#3391,
           &#3378, &#3391, &#3353, &#3405, &#3353, &#3405, &#3378, &#3391,
           &#3384, &#3405, &#3377, &#3405, &#3377, &#3391, &#3378, &#3399,
           &#3349, &#3405, &#3349, &#3405, &#3384, &#3405, &#3381, &#3390,
           &#3351, &#3364, &#3330, &#x0D,  Welcome to Malayalam Wikimedia
           Project's Mailing list" <wikiml-l@lists.wikimedia.org>
    Message-ID:
           <6206ddb40808161301k45e69402kfeca597e9e6a3511@mail.gmail.com>
    Content-Type: text/plain; charset="utf-8"

    #redirect [[???????????? ????]]
    ????? ??? ????? ??????? ?????????? ? ??????? ?????? '???????????? ????'  ????
    ???????????????? ????????? ????.

    16 August 2008 11:49 PM ??, Ramesh N G <rameshng@gmail.com> ?????:

    >  ????????????? ???????? ???? ???????. ??????????...
    >
    > ?????????? ?? ??????? ?????????. ????? ??????? ?????? ????????. ??????????
    > ????? ??????? ????????.
    >
    >
    >
    >
    > 17 August 2008 12:57 AM ??, Jyothis E <jyothis.e@gmail.com> ?????:
    >
    >  ?????? ????????????? ????????????? ??? ??????????? ??????????? ????????.
    >>
    >>
    >> 2008/8/16 Ramesh N G <rameshng@gmail.com>
    >>
    >>>
    >>> ??????????.
    >>>
    >>> ??? ??????? ??????????  ???????????? ?????? ??? ??? ?????????? ?????
    >>>
    >>> ???????: ??????????, ??????????
    >>>
    >>> ?????, ?????.
    >>>
    >>> "?????" ???? ??????????. ???????????? ??????????????. ?????, ?????
    >>> ?????????????. ???????? ????????????
    >>>
    >>> ~~~ ?????.
    >>>
    >>>
    >>>
    >>> 16 August 2008 6:35 PM ??, Ramesh N G <rameshng@gmail.com> ?????:
    >>>
    >>>  ??? ???? ????????? ????? ????? ?????????. ????? ?????? ???????
    >>>> ????????. ???????? ???????????.
    >>>>
    >>>> ?????????????? ??????
    >>>>
    >>>> 16 August 2008 6:31 PM ??, Anoop <anoop.ind@gmail.com> ?????:
    >>>>
    >>>>  ???????????????????. ? ??????<http://ml.wikipedia.org/w/index.php?title=%E0%B4%A8%E0%B5%86%E0%B4%B2%E0%B5%8D%E0%B4%B2%E0%B5%82%E0%B4%B0%E0%B5%8D%E2%80%8D&diff=238968&oldid=238959>????? ????? .
    >>>>> ?????
    >>>>>
    >>>>> 2008/8/16 Ramesh N G <rameshng@gmail.com>
    >>>>>
    >>>>>>   ????????
    >>>>>>
    >>>>>> ????? ??? ????? ???????. ????? ? ????? ??????? ????? ??????????????
    >>>>>> ??????? ???????????. ???????????????  ??????????.
    >>>>>>
    >>>>>> ??? ???????????? ?????? ??????????????? ??????????????.
    >>>>>>
    >>>>>> ???????????? '?????????'<http://ml.wikipedia.org/wiki/%E0%B4%A8%E0%B5%86%E0%B4%B2%E0%B5%8D%E0%B4%B2%E0%B5%82%E0%B4%B0%E0%B5%8D%E2%80%8D>
    >>>>>> ???? ????? ??????? ????????? '?????' ???? ?????? ??????????? ???????????????
    >>>>>> ?????? ??? ????? ??????????????? ????. ???????? ?????<http://ml.wikipedia.org/wiki/%E0%B4%95%E0%B5%8A%E0%B4%9F%E0%B4%95%E0%B4%B0>???? ????? ??????????? ?????.
    >>>>>>
    >>>>>>  ?????.
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> _______________________________________________
    >>>>>> Wikiml-l mailing list
    >>>>>> Wikiml-l@lists.wikimedia.org
    >>>>>> https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    >>>>>>
    >>>>>>
    >>>>>
    >>>>>
    >>>>> --
    >>>>> With Regards,
    >>>>> Anoop
    >>>>> anoop.ind@gmail.com
    >>>>>
    >>>>> _______________________________________________
    >>>>> Wikiml-l mailing list
    >>>>> Wikiml-l@lists.wikimedia.org
    >>>>> https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    >>>>>
    >>>>>
    >>>>
    >>>
    >>> _______________________________________________
    >>> Wikiml-l mailing list
    >>> Wikiml-l@lists.wikimedia.org
    >>> https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    >>>
    >>>
    >>
    >> _______________________________________________
    >> Wikiml-l mailing list
    >> Wikiml-l@lists.wikimedia.org
    >> https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    >>
    >>
    >
    > _______________________________________________
    > Wikiml-l mailing list
    > Wikiml-l@lists.wikimedia.org
    > https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    >
    >
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.wikimedia.org/pipermail/wikiml-l/attachments/20080817/621e72cf/attachment-0001.htm

    ------------------------------

    Message: 2
    Date: Sun, 17 Aug 2008 01:38:27 +0530
    From: "Ramesh N G" <rameshng@gmail.com>
    Subject: Re: [Wikiml-l] ?????? ???????????????? ???????
    To: "&#3374, &#3378, &#3375, &#3390, &#3379, &#3330, &#3381, &#3391,
           &#3349, &#3405, &#3349, &#3391, &#3374, &#3392, &#3361, &#3391,
           &#3375, &#3370, &#3366, &#3405, &#3367, &#3364, &#3391, &#3349,
           &#3379, &#3393, &#3359, &#3398, &#3374, &#3398, &#3375, &#3391,
           &#3378, &#3391, &#3353, &#3405, &#3353, &#3405, &#3378, &#3391,
           &#3384, &#3405, &#3377, &#3405, &#3377, &#3391, &#3378, &#3399,
           &#3349, &#3405, &#3349, &#3405, &#3384, &#3405, &#3381, &#3390,
           &#3351, &#3364, &#3330, &#x0D,  Welcome to Malayalam Wikimedia
           Project's Mailing list" <wikiml-l@lists.wikimedia.org>
    Message-ID:
           <e36c13060808161308k227136c0h8f5184d28965e88f@mail.gmail.com>
    Content-Type: text/plain; charset="utf-8"

    ???? ?????????  ?????????? ???????????, ?????????????? ????? ....

    ~~~?????...



    17 August 2008 1:28 AM ??, Jyothis E <jyothis.e@gmail.com> ?????:

    > ???
    > <http://ml.wikipedia.org/w/index.php?title=%E0%B4%A8%E0%B5%8B%E0%B4%AF%E0%B4%BF%E0%B4%A1&redirect=no>??????...
    >
    >
    >
    > 2008/8/16 Ramesh N G <rameshng@gmail.com>
    >
    >>  ????????????? ???????? ???? ???????. ??????????...
    >>
    >> ?????????? ?? ??????? ?????????. ????? ??????? ?????? ????????. ??????????
    >> ????? ??????? ????????.
    >>
    >>
    >>
    >>
    >> 17 August 2008 12:57 AM ??, Jyothis E <jyothis.e@gmail.com> ?????:
    >>
    >>  ?????? ????????????? ????????????? ??? ??????????? ??????????? ????????.
    >>>
    >>>
    >>>
    >>> 2008/8/16 Ramesh N G <rameshng@gmail.com>
    >>>
    >>>>
    >>>> ??????????.
    >>>>
    >>>> ??? ??????? ??????????  ???????????? ?????? ??? ??? ?????????? ?????
    >>>>
    >>>> ???????: ??????????, ??????????
    >>>>
    >>>> ?????, ?????.
    >>>>
    >>>> "?????" ???? ??????????. ???????????? ??????????????. ?????, ?????
    >>>> ?????????????. ???????? ????????????
    >>>>
    >>>> ~~~ ?????.
    >>>>
    >>>>
    >>>>
    >>>> 16 August 2008 6:35 PM ??, Ramesh N G <rameshng@gmail.com> ?????:
    >>>>
    >>>>  ??? ???? ????????? ????? ????? ?????????. ????? ?????? ???????
    >>>>> ????????. ???????? ???????????.
    >>>>>
    >>>>> ?????????????? ??????
    >>>>>
    >>>>> 16 August 2008 6:31 PM ??, Anoop <anoop.ind@gmail.com> ?????:
    >>>>>
    >>>>>  ???????????????????. ? ??????<http://ml.wikipedia.org/w/index.php?title=%E0%B4%A8%E0%B5%86%E0%B4%B2%E0%B5%8D%E0%B4%B2%E0%B5%82%E0%B4%B0%E0%B5%8D%E2%80%8D&diff=238968&oldid=238959>????? ????? .
    >>>>>> ?????
    >>>>>>
    >>>>>> 2008/8/16 Ramesh N G <rameshng@gmail.com>
    >>>>>>
    >>>>>>>   ????????
    >>>>>>>
    >>>>>>> ????? ??? ????? ???????. ????? ? ????? ??????? ????? ??????????????
    >>>>>>> ??????? ???????????. ???????????????  ??????????.
    >>>>>>>
    >>>>>>> ??? ???????????? ?????? ??????????????? ??????????????.
    >>>>>>>
    >>>>>>> ???????????? '?????????'<http://ml.wikipedia.org/wiki/%E0%B4%A8%E0%B5%86%E0%B4%B2%E0%B5%8D%E0%B4%B2%E0%B5%82%E0%B4%B0%E0%B5%8D%E2%80%8D>
    >>>>>>> ???? ????? ??????? ????????? '?????' ???? ?????? ??????????? ???????????????
    >>>>>>> ?????? ??? ????? ??????????????? ????. ???????? ?????<http://ml.wikipedia.org/wiki/%E0%B4%95%E0%B5%8A%E0%B4%9F%E0%B4%95%E0%B4%B0>???? ????? ??????????? ?????.
    >>>>>>>
    >>>>>>>  ?????.
    >>>>>>>
    >>>>>>>
    >>>>>>>
    >>>>>>> _______________________________________________
    >>>>>>> Wikiml-l mailing list
    >>>>>>> Wikiml-l@lists.wikimedia.org
    >>>>>>> https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    >>>>>>>
    >>>>>>>
    >>>>>>
    >>>>>>
    >>>>>> --
    >>>>>> With Regards,
    >>>>>> Anoop
    >>>>>> anoop.ind@gmail.com
    >>>>>>
    >>>>>> _______________________________________________
    >>>>>> Wikiml-l mailing list
    >>>>>> Wikiml-l@lists.wikimedia.org
    >>>>>> https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    >>>>>>
    >>>>>>
    >>>>>
    >>>>
    >>>> _______________________________________________
    >>>> Wikiml-l mailing list
    >>>> Wikiml-l@lists.wikimedia.org
    >>>> https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    >>>>
    >>>>
    >>>
    >>> _______________________________________________
    >>> Wikiml-l mailing list
    >>> Wikiml-l@lists.wikimedia.org
    >>> https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    >>>
    >>>
    >>
    >> _______________________________________________
    >> Wikiml-l mailing list
    >> Wikiml-l@lists.wikimedia.org
    >> https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    >>
    >>
    >
    > _______________________________________________
    > Wikiml-l mailing list
    > Wikiml-l@lists.wikimedia.org
    > https://lists.wikimedia.org/mailman/listinfo/wikiml-l
    >
    >
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.wikimedia.org/pipermail/wikiml-l/attachments/20080817/c4d14304/attachment.htm

    ------------------------------

    _______________________________________________
    Wikiml-l mailing list
    Wikiml-l@lists.wikimedia.org
    https://lists.wikimedia.org/mailman/listinfo/wikiml-l


    End of Wikiml-l Digest, Vol 1, Issue 11
    ***************************************
Comment 1 Brion Vibber 2009-03-27 22:57:44 UTC
*** Bug 16142 has been marked as a duplicate of this bug. ***
Comment 2 praveenp 2012-02-09 17:36:27 UTC
What requested is not an enhancement. So setting importance normal.
Comment 3 Thehelpfulone 2012-09-09 19:12:21 UTC
Jyothis, is this still an issue? Mailman has been updated since 2008 so it's possible that this has been fixed.
Comment 4 TeleComNasSprVen 2014-07-17 20:56:49 UTC
No response, closing

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links