Last modified: 2010-05-15 16:02:59 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15157 - Make Special:Watchlist look and behave like Special:RecentChanges
Make Special:Watchlist look and behave like Special:RecentChanges
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
1.13.x
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 17:38 UTC by Siebrand Mazeland
Modified: 2010-05-15 16:02 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Siebrand Mazeland 2008-08-13 17:38:03 UTC
[[Special:RecentChanges]] contains a few features that [[Special:Watchlist]], which is a very similar page, does not have. It would be more consistent, and convenient, if these two page would look and behave the same. With some refactoring, they could probably use mostly the same code.

These are the ones I found, possibly there are more:
* "Show/Hide anonymous users" missing in Watchlist
* "Show/Hide logged-in users" missing in Watchlist
* "Invert selection" next to namespace drop down menu missing in Watchlist
* "contribs" link behind editor missing in Watchlist
* order of currently available Show/Hide options differs
Comment 1 Raimond Spekking 2008-08-13 17:40:44 UTC
And the watchlist is missing the nice fieldset too :) 
Comment 2 Siebrand Mazeland 2008-08-13 17:45:12 UTC
Inspired by bug 14658 (Namespace selection via checkboxes on Special: Watchlist instead of drop down)
Comment 3 Siebrand Mazeland 2008-08-13 23:09:09 UTC
The following were implemented with r39314.
* "Show/Hide anonymous users" missing in Watchlist
* "Show/Hide logged-in users" missing in Watchlist
* "Invert selection" next to namespace drop down menu missing in Watchlist
* order of currently available Show/Hide options differs
* added new options to preferences tab Watchlist

Invalid:
* "contribs" link behind editor missing in Watchlist

Still missing:
* Nice fieldset from comment 1.
Comment 4 Charlotte Webb 2008-08-14 20:00:54 UTC

*** This bug has been marked as a duplicate of bug 14485 ***
Comment 5 Siebrand Mazeland 2008-08-15 07:48:34 UTC
Re-opened because the fieldset is still missing. I will try to get that in this weekend.
Comment 6 Siebrand Mazeland 2008-08-23 16:47:59 UTC
Fieldset was added by ^demon in r39839. RESOLVED.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links