Last modified: 2008-07-25 18:30:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 14924 - Images with Non-ASCII characters don't work with Windows Server
Images with Non-ASCII characters don't work with Windows Server
Status: RESOLVED DUPLICATE of bug 1780
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
unspecified
PC Windows Server 2003
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-25 18:28 UTC by D J Bauch
Modified: 2008-07-25 18:30 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description D J Bauch 2008-07-25 18:28:28 UTC
This issue is separate from bug 9767 (Microsoft SQL Server support), although I encounter it in that context. Images with non-ASCII characters in their names are being stored by mediawiki upon upload, but then are not subsequently found for display.
For example, the image Image:Flagge Preußen - Provinz Hessen-Nassau.svg is sought at the location http://.../mediawiki/index.php?title=Image:Flagge_Preu%C3%9Fen_-_Provinz_Hessen-Nassau.svg. This is stored on the Windows file system at upload time with the name .../images/2/28/Flagge_Preußen_-_Provinz_Hessen-Nassau.svg. Changing the name of that file to .../images/2/28/Flagge Preußen - Provinz Hessen-Nassau.svg causes everything to work fine.
Comment 1 Max Semenik 2008-07-25 18:30:07 UTC

*** This bug has been marked as a duplicate of bug 1780 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links