Last modified: 2010-05-15 16:03:45 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 14790 - Special:Export remove "Category:" (or local name) from text box
Special:Export remove "Category:" (or local name) from text box
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
1.13.x
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Special:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-11 17:21 UTC by Sam Reed (reedy)
Modified: 2010-05-15 16:03 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sam Reed (reedy) 2008-07-11 17:21:36 UTC
Would it be possible for when the user presses "Add" that if they have put "Category:" (or whatever the localised version is), that it is removed by the software

I've done it a couple of times with it in, and then am like WTF when it doesnt work


Cheers!
Comment 1 Sam Reed (reedy) 2008-07-11 18:43:46 UTC
Changing to Enhancement (as it isnt really a bug)
Comment 2 Brion Vibber 2008-07-30 23:19:36 UTC
I'd say this is a real bug, since we usually accept such things with namespace prefixes with no problem.


Steps to reproduce:

1) Go to http://en.wikipedia.org/wiki/Special:Export

2) In "Add pages to from category" box type "Category:Long Island"

3) Click "Add" button


Expected results:

A bunch of pages from http://en.wikipedia.org/wiki/Category:Long_Island should be listed in the export page list box.


Actual results:

No pages are listed.


Workaround:

Type "Long Island" without the "Category:" namespace prefix.


Suggested fix:

Normalize the category name more sensible in Special:Export, so that category names are accepted both with and without the 'Category:' prefix.
Comment 3 Sam Reed (reedy) 2008-07-31 09:20:59 UTC
Cheers Brion,

I suppose, its only a case of sending it to a function thats already written and having the normalised title sent back
Comment 4 Siebrand Mazeland 2008-08-11 21:55:40 UTC
Fixed in r39184.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links