Last modified: 2010-05-15 15:59:49 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 12090 - Attempts to upload large PDFs fail without error message (may be true for all large files)
Attempts to upload large PDFs fail without error message (may be true for all...
Product: MediaWiki
Classification: Unclassified
Uploading (Other open bugs)
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2007-11-24 17:29 UTC by Daniel Trebbien
Modified: 2010-05-15 15:59 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---

A screenshot of the filled-out form (95.54 KB, image/gif)
2007-12-06 19:19 UTC, Daniel Trebbien
A screenshot of the page I see after clicking "Upload file" (95.19 KB, image/gif)
2007-12-06 19:20 UTC, Daniel Trebbien

Description Daniel Trebbien 2007-11-24 17:29:40 UTC
Whenever I attempt to upload a large PDF file (9 Mb is "large", but I don't know the minimum cutoff), the resulting page is a blank Special:Upload page. There is no error message, so I don't know what's wrong. I believe, however, that the file was uploaded, which is why I think that there is a bug in MediaWiki.

The following are the only changes to MediaWiki software that I have made (to LocalSettings.php):

$wgGroupPermissions['*']['createaccount'] = false;
$wgGroupPermissions['*']['read'] = false;
$wgGroupPermissions['*']['edit'] = false;
$wgGroupPermissions['*']['createpage'] = false;
$wgGroupPermissions['*']['createtalk'] = false;
$wgEnableUploads = true;
$wgStrictFileExtensions = false;
$wgAllowCopyUploads = true;
$wgUploadSizeWarning = 10*1024*1024;
$wgUseTeX = true;
$wgLaTexCommand = "C:/MiKTeX/main/miktex/bin/latex.exe";
$wgDvipsCommand = "C:/MiKTeX/main/miktex/bin/dvipng.exe";
$wgEnableScaryTranscluding = true;
$wgDefaultSkin = "common";
#$wgShowExceptionDetails = true;
require_once( $IP.'/extensions/Cite.php' );
require_once( $IP.'/extensions/InterWiki.php' );
function simpleWhitelistUserCan($title, $user, $action, $result)
	if($title=='User:Dtrebbien/Adblock Plus list')
		return false;
	return true;
$wgHooks['userCan'][] = 'simpleWhitelistUserCan';

Note that the Cite extension is one used by Wikipedia and the InterWiki extension is the one from Organic Design.

I am using xcache (no other caching software).

These are the relevant settings from php.ini:

; File Uploads ;
; Whether to allow HTTP file uploads.
file_uploads = On
; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
;upload_tmp_dir =
; Maximum allowed size for uploaded files.
upload_max_filesize = 40M

so I think that it is not that I have misconfigured PHP.

I have tried to upload two, different "large" PDFs as a Sysop, so I don't think that there is some problem with corrupted PDFs or permissions.

As an example, try to upload: (9.34 Mb)
Comment 1 Brion Vibber 2007-12-06 18:19:54 UTC
Blank page usually means a PHP fatal error. A likely possibility is that the memory limit was exhausted.

Check your PHP error reporting and logging settings and your web server's error log.
Comment 2 Daniel Trebbien 2007-12-06 19:18:44 UTC
Hi Brion,

I was ambiguous with "blank Special:Upload page". The resulting page is not blank as in completely white. Instead, it looks exactly as if I had visited Special:Upload.

I'll post some screenshots. "Clipboard01.gif" is a screenshot of the filled-out form (for uploading the test file ssdv004.pdf). "Clipboard02.gif" is a screenshot of the page I see after clicking "Upload file".

I am running the server on a new computer with 1Gb of RAM, so I don't think that the action exhausted memory. Additionally, I can use the download form to upload other (smaller) PDFs, but for some reason not large ones.

Comment 3 Daniel Trebbien 2007-12-06 19:19:01 UTC
Created attachment 4411 [details]
A screenshot of the filled-out form
Comment 4 Daniel Trebbien 2007-12-06 19:20:00 UTC
Created attachment 4412 [details]
A screenshot of the page I see after clicking "Upload file"
Comment 5 Daniel Trebbien 2007-12-26 17:38:52 UTC
I fixed it. The problem was that the `post_max_size` option in php.ini was not high enough.

My apologies for filing a bug report.

Note You need to log in before you can comment on or make changes to this bug.