Last modified: 2014-05-22 18:09:14 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 9832 - SVG thumbnail is cropped when displayed at natural size
SVG thumbnail is cropped when displayed at natural size
Status: NEW
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
1.10.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://test.wikipedia.org/wiki/User:S...
: testme, upstream
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-07 21:42 UTC by Tim Starling
Modified: 2014-05-22 18:09 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
example of IM rendering of file in question. (28.32 KB, image/png)
2012-10-31 12:47 UTC, Derk-Jan Hartman
Details

Description Tim Starling 2007-05-07 21:42:09 UTC
Sundance_Raphael reports that natural size SVG thumbnails for a certain image
appear cropped, when rendered with Inkscape or ImageMagick. This was apparently
a regression from 1.9 to 1.10. The source image is:

http://commons.wikimedia.org/wiki/Image:Chlamydomonas.svg

It works fine on commons, so the issue probably does not affect librsvg. There
are screenshots are at:

http://test.wikipedia.org/wiki/User:Sundance_Raphael

By natural size, I mean that no width was specified in the image link.
Comment 1 Anne 2007-05-07 22:12:57 UTC
thumbs with a size ending on zero (180px.. ) are ok, if the last numer is
between 1-9 no thumb is generated
Comment 2 Anne 2007-05-08 11:29:02 UTC
correction only the thumbs with a size off 200px, 300px were shown and the size
of 177px (orginal size) would shown misformt
Comment 3 Anne 2007-05-08 13:08:06 UTC
ImageMagick is the problem. It can show thumbs and svg right with was generated
from Inscape in the MW, but it is not able to reader the .svg right in .png . 
Comment 4 Brion Vibber 2009-08-03 16:53:49 UTC
Assigning SVG bugs to Ariel -- need a cleanup pass to see what's fixed up by a librsvg upgrade, what can be resolved with fixes to our font configuration, what can be fixed on our end, and what still needs to be pushed upstream.
Comment 5 Derk-Jan Hartman 2010-11-04 03:22:55 UTC
issue still exists with ImageMagick 6.6.4-0 2010-09-29 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2010 ImageMagick Studio LLC
Features: OpenMP 

It also takes imagemagick rather long to render the SVG, so it's probably running into some kind of error situation.
Comment 6 Ariel T. Glenn 2011-09-18 09:23:22 UTC
giving SVG bugs back to the pool.
Comment 7 Andre Klapper 2012-05-09 11:31:01 UTC
> issue still exists with ImageMagick 6.6.4-0 2010-09-29 Q16

How to test this exactly?
Comment 8 Andre Klapper 2012-10-30 15:35:39 UTC
(In reply to comment #0)
> There are screenshots are at:
> http://test.wikipedia.org/wiki/User:Sundance_Raphael

Not anymore. :(

Note that servers reserved an upgrade to Ubuntu 12.04 recently, so testing (or providing instructions how to test) is welcome.
Comment 9 Derk-Jan Hartman 2012-10-31 12:45:50 UTC
Download http://commons.wikimedia.org/wiki/Image:Chlamydomonas.svg and render with your Mediawiki + ImageMagick (default if there is no rsvg) to convert the svg to png. (Note that Wikimedia uses librsvg for PNG rendering of SVG and not ImageMagick).

I still see this issue with 6.8.0-2 version of ImageMagick on my machine. I'm not really sure if this is an ImageMagick bug, or if we are just not using ImageMagick correctly.
Comment 10 Derk-Jan Hartman 2012-10-31 12:47:34 UTC
Created attachment 11267 [details]
example of IM rendering of file in question.
Comment 11 Bawolff (Brian Wolff) 2014-05-22 18:09:14 UTC
(In reply to Derk-Jan Hartman from comment #9)
> Download http://commons.wikimedia.org/wiki/Image:Chlamydomonas.svg and
> render with your Mediawiki + ImageMagick (default if there is no rsvg) to
> convert the svg to png. (Note that Wikimedia uses librsvg for PNG rendering
> of SVG and not ImageMagick).
> 
> I still see this issue with 6.8.0-2 version of ImageMagick on my machine.
> I'm not really sure if this is an ImageMagick bug, or if we are just not
> using ImageMagick correctly.

Seems to work for me on ImageMagick 6.6.0-4 2010-11-16 Q16 for me, but I think my image magick may have been compiled to use rsvg instead of the internal thing.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links