Last modified: 2007-11-06 09:13:40 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 9783 - First time SMWAdmin Initialisation fails with error 1064
First time SMWAdmin Initialisation fails with error 1064
Status: RESOLVED DUPLICATE of bug 11704
Product: MediaWiki extensions
Classification: Unclassified
Semantic MediaWiki (Other open bugs)
unspecified
PC Linux
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://www.travvy.info/wiki
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-04 03:47 UTC by Travis D. Reed
Modified: 2007-11-06 09:13 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Travis D. Reed 2007-05-04 03:47:20 UTC
I have just set up MediaWiki 1.9.* on my web server and installed the latest
version of SMW.  I have followed the appropriate steps, but when I go to
Special:SMWAdmin and click the initialisation button, I get the following error:

  from within function "SMW::setupDatabase". MySQL returned error "1064: You
have an error in your SQL syntax; check the manual that corresponds to your
MySQL server version for the right syntax to use near '-_wikidb.`smw_relations`
( subject_id INT(8) UNSIGNED NOT NULL, ' at line 1 (localhost)".

As you partially see, my database has the name travvy_info_-_wikidb.  That
prefix is mandated by my webhost.  Is the hyphen causing the problem or is it
just a coincidence the problem starts there?
Comment 1 Markus Krötzsch 2007-11-06 09:13:40 UTC

*** This bug has been marked as a duplicate of bug 11704 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links