Last modified: 2010-05-15 15:48:29 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 9632 - PHP Fatal error
PHP Fatal error
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
1.9.x
PC Windows Server 2003
: High major (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 18:07 UTC by Shawn Beard
Modified: 2010-05-15 15:48 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Shawn Beard 2007-04-19 18:07:14 UTC
When editing a page, saving, then going back to the previous page, it comes up 
with a blank page.  The below error occurs in the error log.  This causes me to 
have to restart Apache 2.2.4 to get mediawiki working again.

[Thu Apr 19 12:55:55 2007] [error] [client 172.28.132.70] PHP Fatal error:  
Cannot redeclare wfprofilein() (previously declared in D:\\IHS\\6.0
\\htdocs\\en_US\\wiki\\includes\\ProfilerStub.php:7) in D:\\IHS\\6.0
\\htdocs\\en_US\\wiki\\includes\\ProfilerStub.php on line 12, referer: 
http://wasasb2.fbfs.com/wiki/index.php/Workflow_Load_Balancing_with_F5_on_wasaup
q9_and_wasaupq10
[Thu Apr 19 12:57:22 2007] [error] [client 172.28.132.221] PHP Fatal error:  
Cannot redeclare wfprofilein() (previously declared in I:0) in D:\\IHS\\6.0
\\htdocs\\en_US\\wiki\\includes\\ProfilerStub.php on line 12, referer: 
http://wasasb2.fbfs.com/wiki/index.php/WebSphere_Environments#WebSphere_v6.0_Tes
t_Environment
Comment 1 Brion Vibber 2007-04-25 19:21:22 UTC
I'd suspect a broken PHP acceleration extension (Zend Optimizer, eAccelerator, etc).
Comment 2 Shawn Beard 2007-04-25 19:23:18 UTC

(In reply to comment #1)
> I'd suspect a broken PHP acceleration extension (Zend Optimizer, 
eAccelerator, etc).

How can that be fixed?
Comment 3 Brion Vibber 2007-04-25 19:24:29 UTC
Remove, upgrade, downgrade, debug it? :) Try some different versions and
environments.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links