Last modified: 2010-05-15 15:48:28 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 9494 - image resizing (thumbs do not appear) !!!
image resizing (thumbs do not appear) !!!
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
1.9.x
PC Windows XP
: Highest normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-04 06:53 UTC by Ahmad
Modified: 2010-05-15 15:48 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ahmad 2007-04-04 06:53:51 UTC
hi ...
when I resize images like [[image:learn.jpg|300px]] it doesn't show any image
(thumbs) and doesn't give me any error ...just an empty rectangle of the thumb
size (300px) with X sign at the top left of that empty rectangle !!! .... I
tried something I found in one of the forums, to commented these lines (in  
\wiki\includes\Image.php):

#$cmd = $wgCustomConvertCommand;
#$cmd = str_replace( '%s', $src, str_replace( '%d', $dst, $cmd ) ); # Filenames
#$cmd = str_replace( '%h', $height, str_replace( '%w', $width, $cmd ) ); # Size

And instead add this :
$cmd = $wgImageMagickConvertCommand .
" -quality 85 -background white -geometry {$width} ".
($this->imagePath) . " " .
($thumbPath);

It works with them but didn't work with me!!!

* I'm sure that the converter works because when I opened the image/thumb
directory I found thumbs with the sizes I've tried on.
* I gave permission for both the IUSR_* and IWAM_* on both the Image directory
and the whole directory that contains the the "convert" ....

waiting for your help 
regards,
Comment 1 Rob Church 2007-04-04 06:56:52 UTC
BugZilla is not a support ticket queue; please contact the mediawiki-l mailing list.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links