Last modified: 2010-05-15 15:48:32 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 9095 - bad xhtml formation in page rendering when updating a image
bad xhtml formation in page rendering when updating a image
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
1.9.x
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: html
  Show dependency treegraph
 
Reported: 2007-02-25 09:29 UTC by sspecter
Modified: 2010-05-15 15:48 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description sspecter 2007-02-25 09:29:14 UTC
Hi

I have a wiki in xhml and Im having some problem
When I post a image, and then update it to another image the xhtml brake up due
to a bad-formed tag, which contain tag inside tag and bad formed strings inside
the tag string.

The bad formed tag is the following:
<a href="/wiki/index.php?title=Special:Upload&amp;wpDestFile=%241" class="new"
title="Imagem:<a href="/wiki/images/8/83/image_name.gif" class="internal"
title="image_name.gif">Funcoes circulares.gif</a>">

Although the image update is always successful, doing it in xhtml wikis/skins
will always lead to a broken page.
Comment 1 sspecter 2007-02-25 09:32:46 UTC
Correction: the bad formed tag is (as my wiki is in portuguese and i mixed
portuguese+english):
<a href="/wiki/index.php?title=Special:Upload&amp;wpDestFile=%241" class="new"
title="Image:<a href="/wiki/images/8/83/image_name.gif" class="internal"
title="image_name.gif">image_name.gif</a>">
Comment 2 Brion Vibber 2007-03-05 20:08:33 UTC
Where exactly do you see this?
Comment 3 Chad H. 2009-01-24 04:34:37 UTC
Can't seem to find/replicate this anywhere. Closing as WFM.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links