Last modified: 2010-05-15 15:48:24 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 8992 - $_SERVER['REQUEST_URI'] undefined on IIS 5.0, Patch included
$_SERVER['REQUEST_URI'] undefined on IIS 5.0, Patch included
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.9.x
PC Windows 2000
: Low trivial (vote)
: ---
Assigned To: Nobody - You can work on this!
: patch
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-15 10:59 UTC by Daniel Schömer
Modified: 2010-05-15 15:48 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Patch for bug #8992 (584 bytes, patch)
2007-02-15 11:01 UTC, Daniel Schömer
Details
Additional patch for bug #8992 (544 bytes, patch)
2008-10-23 17:28 UTC, Andrea Matsunaga
Details

Description Daniel Schömer 2007-02-15 10:59:52 UTC
Running Mediawiki 1.9.2 on Windows 2000 Server with Internet Information 
Services 5.0.

On a page history, the following PHP warning gets displayed:

  Notice: Undefined index: REQUEST_URI in ...\includes\Wiki.php on line 427

The following patch eleminates the warning for me:

=== modified file 'includes/Wiki.php'
--- includes/Wiki.php   2007-02-14 10:57:34 +0000
+++ includes/Wiki.php   2007-02-15 10:43:47 +0000
@@ -422,7 +422,8 @@
                                }
                                break;
                        case 'history':
-                               if( $_SERVER['REQUEST_URI'] == $title-
>getInternalURL( 'action=history' ) ) {
+                               $request_uri = 
array_key_exists('REQUEST_URI', $_SERVER) ? $_SERVER['REQUEST_URI'] : 
$_SERVER['ORIG_PATH_INFO'];
+                               if( $request_uri == $title-
>getInternalURL( 'action=history' ) ) {
                                        $output->setSquidMaxage( $this-
>getVal( 'SquidMaxage' ) );
                                }
                                $history = new PageHistory( $article );
Comment 1 Daniel Schömer 2007-02-15 11:01:23 UTC
Created attachment 3224 [details]
Patch for bug #8992

Attached patch
Comment 2 Brion Vibber 2007-02-15 23:43:50 UTC
Correct fix is to use $wgRequest functions as done elsewhere for bug 3000; this
one apparently missed the boat. :)

Fixed on trunk in r19956, REL1_9 in r19957
Comment 3 Andrea Matsunaga 2008-10-23 17:28:53 UTC
Created attachment 5452 [details]
Additional patch for bug #8992

Resolves similar issue with REQUEST_URI in includes/Article.php.
Comment 4 Alex Z. 2008-10-23 20:46:12 UTC
Done in r42400.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links