Last modified: 2012-02-21 11:12:05 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 8797 - Some greek characters don't render in SVG
Some greek characters don't render in SVG
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
SVG rendering (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://commons.wikimedia.org/wiki/Ima...
:
Depends on:
Blocks: svg
  Show dependency treegraph
 
Reported: 2007-01-27 22:12 UTC by Daniel Kinzler
Modified: 2012-02-21 11:12 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Daniel Kinzler 2007-01-27 22:12:05 UTC
Apparently, rsvg refuses to render some greek letters, namely the captial delta
and capital mu (for the later see
http://commons.wikimedia.org/wiki/Image:Greek_letter_mu.svg). Trying with rsvg
(2.16.0) on my box, it works fine. Changing the font from "Times" to "serif"
didn't help. Is there something odd about the fonts installed on the WMF boxes?
Comment 1 Paolo Liberatore 2007-02-02 13:16:48 UTC
Just a small correction to the summary: it's the small mu that is not rendered.
Comment 2 Badseed 2007-03-26 19:00:11 UTC
It's not just that; any character that is stressed (greek language uses
stresses) fails to appear after the rasterization. You can see any letter when
viewing the svg in full resolution, but mu, upsilon and the stressed characters
fail to appear when the picture is in preview or thumb. The only solution to
this is converting text into paths, which increases the file size and is
time-consuming too.
Comment 3 Tim Starling 2007-04-18 22:30:43 UTC
Test case is fixed after installing more fonts.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links