Last modified: 2007-01-18 13:37:10 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 8688 - Spaces in usernames causes error in unblock interface
Spaces in usernames causes error in unblock interface
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
User blocking (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-18 13:13 UTC by brianna.laugher
Modified: 2007-01-18 13:37 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description brianna.laugher 2007-01-18 13:13:45 UTC
Hello,

I tried to unblock a user whose username has a space in it, let's say
[[User:This user]]. I went to their userpage, I clicked on 'Block user' in the
toolbox, followed a link like this -
http://commons.wikimedia.org/w/index.php?title=Special:Ipblocklist&action=unblock&ip=This_user
that said 'Unblock This user'. Then in the 'IP address or username' field, it
had 'This_user'. I filled in the reason and clicked 'Unblock this address'. 

Then I got an error message which I can't perfectly remember (sorry), but it was
to the effect of 'this user is not currently blocked' or maybe 'we can't find
this user'. I went back and changed the underscore in the 'IP address or
username' field to a space, and then it worked.

So this is a very longwinded way of saying that the underscore is undesirably
propogating to the unblock page and I hope this is enough information to
identify and fix the problem.

thanks!
Comment 1 Rob Church 2007-01-18 13:37:10 UTC
Should be fixed (both ends) in r19449.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links