Last modified: 2012-02-22 12:35:16 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 8660 - Problem with endashes and emdashes in article names
Problem with endashes and emdashes in article names
Status: RESOLVED WONTFIX
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
PC Windows XP
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 640
  Show dependency treegraph
 
Reported: 2007-01-16 19:12 UTC by Matthias Becker
Modified: 2012-02-22 12:35 UTC (History)
5 users (show)

See Also:
Web browser: Internet Explorer
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Matthias Becker 2007-01-16 19:12:05 UTC
Article names are getting part of the title of the HTML concerned using the name
within <title>Any article's name - Wikipedia the free encyclopedy</title>. If
the article name includes an endash or emdash the problem occurs.

The problem effects on systems from W95/98 until XP when IE 6 is used and to my
knowledge even if all the latest SPs are installed, both for IE and XP. IE 6 by
default is saving a HTML file by using the HTML page's title. While XP has no
problem with saving the dash as a dash, since ALT+0150 or ALT+0151 are valide
characters for naming files in Windows systems, such a file can't be reopened in
IE 6 without loosing styles and graphics because the browser doesn't recognise
the sub-directory in which css and pics are stored. (FYI, IE 5 would fail to
open the file in total).

The issue doesn't occur with IE 7 where certainly due to an internal
Microsoft-propriety  solution the browser is capable to deal with the problem.
However, IE 7 isn't a true alternative, since it isn't available (yet) in many
languages, e.g. Czech, Slovakian, Hungarian and several other CE languages or
can't be installed on many systems used in those countries (systems older than
XP are still widespreaded in Eastern Europe).

Solution: Making sure that endash or emdash isn't used as a character in the
text string between the tags <title> and </title>, either by a manual of style
or better by a software feature. Clearly this has to override typographical
usancies, mainly in US or British English.

Note: It is believed that the left and right single quotes (but not the
abstroph) does cause the same problem. If so it should be part of the same
problem solution.
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-01-25 03:19:36 UTC
If this is an issue, it's probably with everything in MS's proprietary [[Windows-1252]] ranges.
Comment 2 Siebrand Mazeland 2009-06-04 11:05:07 UTC
Update Web browser.
Comment 3 Siebrand Mazeland 2009-06-04 11:35:34 UTC
Adding testme. Please test with Internet Explorer 8 and note the result here.
Comment 4 Chris Eagle 2009-09-21 01:26:28 UTC
The problem as described does not occur with IE8.
Comment 5 Manfred Krüger 2009-10-10 17:30:50 UTC
When dashes lead to problems in old browsers - why are they used in the message files of MediaWiki? Example: &ndash is used in MessagesDe.php of Version 1.15.0 for the message 'pagetitle' (and more).
Comment 6 Niklas Laxström 2009-10-11 14:19:25 UTC
(In reply to comment #5)
> When dashes lead to problems in old browsers - why are they used in the message

Because everyone thought that all the bugs in Internet Explorer were known and that it couldn't suck even more. Or just that we didn't know. The only thing to do here would be to convert longer dashes into plain dash, but I don't see that happening.
Comment 7 Dan Collins 2011-07-12 05:01:18 UTC
No one seems really enthusiastic about fixing this, and our affected userbase is only people using IE 6 or earlier on Windows XP or earlier, which is small and dwindling, and only barely considered supported. It doesn't appear that we're violating any HTML standard by using endash or emdash, so I'm going to call this wontfix.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links