Last modified: 2007-03-19 16:20:42 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 8324 - https links not searchable via Special:Linksearch
https links not searchable via Special:Linksearch
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://wikimediafoundation.org/w/inde...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 18:49 UTC by Brion Vibber
Modified: 2007-03-19 16:20 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Brion Vibber 2006-12-19 18:49:01 UTC
https: links cannot be searched via Special:Linksearch; no results are returned.

This appears to be because the el_index field is blank for https entries.

Recommended fix: fill out el_index for https (and others?) as it is done for http.
Comment 1 Rob Church 2006-12-19 18:54:11 UTC
wfMakeUrlIndex() in includes/GlobalFunctions.php includes these lines:

if ( !$bits || $bits['scheme'] !== 'http' ) {
	return false;
}
Comment 2 Walter Vermeir 2007-03-16 11:14:48 UTC
I was going to submit the same problem but have found this ticket. 

On NL Wikipedia someone had posted a fake "donate to Wikipedia"-link in an article. 
Url's to http://wwww.paypal.com can be found with the [[Special:Linksearch]] function 
but still not "https"-versions. Please add this.

And maybe also include some other protocols like:
gopher://
ftp://
irc://
Comment 3 Raimond Spekking 2007-03-16 22:02:05 UTC
Fixed with r20530. Searching now for http/https/ftp/irc/news available (gopher
seems me to old/not relevant).

Please note, that existing weblinks other than http are not indexed (el_index)
until the link is edited and the paged is saved again.
Comment 4 Raimond Spekking 2007-03-19 16:20:42 UTC
Reworked with r20561. Works now for all protocols definded in $wgUrlProtocols
incl. email.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links