Last modified: 2010-05-15 15:42:44 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 8313 - Zend Optimizer 3.2.0 with PHP 5.2.0 inexplicably dies in counter formatting
Zend Optimizer 3.2.0 with PHP 5.2.0 inexplicably dies in counter formatting
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.8.x
PC Linux
: Lowest normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://www.naturalinclusion.com/wiki/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 06:00 UTC by Jan Jaap
Modified: 2010-05-15 15:42 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jan Jaap 2006-12-19 06:00:51 UTC
Dear MediaWiki development team,

MediaWiki doesn't seem to be working on the latest version of PHP (5.2.0), MySQL (5.1.14beta) and ZEND 
(3.2?).

I have tried to install MediaWiki for some days now. I am hosted with prohosters.com who install 
anything upon request and have an elite techteam available for the most dificult issues and 
demands/configurations.

After 3 full reinstalations of PHP 5.2 by 3 difrent techs, they forwarded the issue to their elite 
techteam called Escalated techs. They have spend mutliple hours trying to solve the problem, and upgrade 
MySQL from 5.1.11 to 5.1.14beta and tried to solve the problem.

When ZEND is disabled MediaWiki works fine, when enabled however it doesn't work anymore.

Best Regards,
Jan Jaap Hakvoort

PHP 5.2.0 installed 
Found database drivers for: MySQL PostgreSQL 
PHP server API is apache2handler; ok, using pretty URLs (index.php/Page_Title) 
Have XML / Latin1-UTF-8 conversion support. 
PHP's memory_limit is 80M. If this is too low, installation may fail! 
Have zlib support; enabling output compression. 
Couldn't find Turck MMCache, eAccelerator or APC. Object caching functions cannot be used.
Found GNU diff3: /usr/bin/diff3.
Found ImageMagick: /usr/local/bin/convert; image thumbnailing will be enabled if you enable uploads. 
Found GD graphics library built-in. 
Installation directory: /home/webadmin/naturalinclusion.com/html/wiki 
Script URI path: /wiki 
Environment checked. You can install MediaWiki.
Comment 1 Jan Jaap 2006-12-19 06:16:58 UTC
This is my PHP.ini: http://www.naturalinclusion.com/wiki/php.txt
Comment 2 Jan Jaap 2006-12-19 06:26:04 UTC
Here are the error logs http://www.naturalinclusion.com/wiki/logs/
Comment 3 Jan Jaap 2006-12-19 13:08:03 UTC
It's a blocker for all users using the latest version of PHP 5.2.0 wich is even recomended by MediaWiki!
Comment 4 Rob Church 2006-12-19 13:09:21 UTC
It's not a blocker for me, and I use PHP 5.2.0. I'm guessing it's another
reincarnation of one of several Zend weirdness issues.

Please don't mess about with priorities; they're there for our use.
Comment 5 Jan Jaap 2006-12-19 13:15:31 UTC
Hello, it's a ZEND bug yes. But since a lot of users use zend it's a blocker for those users.
Comment 6 Raj Shekhar 2006-12-19 13:21:41 UTC
Jan Jaap, won't it be better to file a bug with zend about it ?  If you want
tips on how to collect a backtrace for this, I can give you some help for that
Comment 7 Brion Vibber 2006-12-19 18:26:34 UTC
As discussed on IRC, workaround is to set $wgDisableCounters = true;
This is probably a low-level problem with Zend Optimizer.
Comment 8 s3lh 2006-12-21 16:19:15 UTC
yes,it happend for mew now
when i install a zend,wiki is wrong.delete zend,wiki is ok
but other soft must use zend,my god

php: 5.1.6
ZendOptimizer: 3.2.0  or  3.0.2
mysql: 5.0.27

my wrong notice is :PHP has encountered an Access Violation at 02533F62
Comment 9 Patriarch Anthony I 2006-12-27 21:38:48 UTC
I can confirm that the $wgDisableCounters = true; in the localsettings.php fixed
my problem. 

I am using:

Mediawiki 1.8.2
Php 5.2.0 (cgi)
Zend Optimizer 3.2.0
Linux 
MySQL 4.1.21
Comment 10 Brion Vibber 2007-01-15 22:34:30 UTC
This one was fixed...

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links