Last modified: 2006-12-14 07:04:19 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 8215 - MultiUpload returns error when used
MultiUpload returns error when used
Status: RESOLVED INVALID
Product: MediaWiki extensions
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
PC Linux
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-11 07:31 UTC by Jan Vansteenkiste
Modified: 2006-12-14 07:04 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jan Vansteenkiste 2006-12-11 07:31:07 UTC
When I tried using the MultipleUpload Special page I got an error that the
function wfRunHooks was not found.
I fixed it by adding require_once("../Hooks.php") in SpecialPage.php.

I suppose Hooks.php should be loaded before any specialpage-extension gets loaded.
Comment 1 Brion Vibber 2006-12-11 20:19:20 UTC
Hooks.php will always have been already loaded by the time your setup function
is run.

Make sure you're not trying to run code at initial include time!
Comment 2 Rob Church 2006-12-12 04:22:22 UTC
(In other words, use $wgExtensionFunctions[] = 'efBlahBlah' and put setup code,
such as that which interacts with hooks, in function efBlahBlah() { })
Comment 3 Aryeh Gregor (not reading bugmail, please e-mail directly) 2006-12-13 17:09:23 UTC
Well, if this is a problem with how the extension is being executed, then
shouldn't it be fixed?  MultiUpload is in SVN.  It doesn't seem to call
wfRunHooks anywhere that I can see offhand, though.  Is this a problem with
MultiUpload or some other extension or something else entirely?

Jan Vansteenkiste: Where did you encounter this error?  Do you have a link?
Comment 4 Jan Vansteenkiste 2006-12-14 07:04:19 UTC
The extension seems to be running  
 SpecialPage::AddPage(new SpecialPage('MultipleUpload'));

Before the $wgExtensionFunctions.
I fixed it by cutting that out and placing it within the function.

 function wfMultipleUpload() {
    SpecialPage::AddPage(new SpecialPage('MultipleUpload'));

Somebody should probably correct this in the svn in the file SpecialMultipleUpload.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links