Last modified: 2006-11-17 03:35:02 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 7919 - "Pages transcluded onto ... this page:" in protected page
"Pages transcluded onto ... this page:" in protected page
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 13:43 UTC by ChemicalBit
Modified: 2006-11-17 03:35 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Non-functional patch (2.81 KB, patch)
2006-11-17 03:04 UTC, Aryeh Gregor (not reading bugmail, please e-mail directly)
Details

Description ChemicalBit 2006-11-14 13:43:23 UTC
As I was looking closely at the template list just below edit textarea in edit
page ("Pages transcluded onto the current version of this page:" in english
interface)
(see http://bugzilla.wikimedia.org/show_bug.cgi?id=7918 that I've just submited)

I find out that if the page is protected, the  "view source" page (instead of
the "edit page") have no list at all of templates transcluded.

This would be useful -for example- to find out which template is used in a
(protected) page "I want to use it in the page I'm writing too"
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2006-11-17 03:04:50 UTC
Created attachment 2717 [details]
Non-functional patch

This patch doesn't seem to work . . . why is $wgArticle undefined in
OutputPage.php?  How else can I do what I'm trying to do?  Hmm.  Maybe later.
Comment 2 Aryeh Gregor (not reading bugmail, please e-mail directly) 2006-11-17 03:35:02 UTC
Fixed in r17739 (nobody told me "new Article" meant Article::newFromTitle!).

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links