Last modified: 2010-05-15 15:28:21 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 790 - Page Move does not check if target is a talk page
Page Move does not check if target is a talk page
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.3.x
PC Windows XP
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://furc.zapto.org/Wiki/index.php?...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-26 23:01 UTC by Jamie Bliss
Modified: 2010-05-15 15:28 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jamie Bliss 2004-10-26 23:01:51 UTC
If you move a page to a namespace that would be a talk page (sepperate from 
the main page), it will set up the target to be a article, not a talk page.

See http://furc.zapto.org/Wiki/index.php?
title=Talk:PICSim&redirect=no , .../index.php/Spec_Talk:PICSim , 
and .../index.php/Spec_Talk:PICSim for details.
Comment 1 Brion Vibber 2004-10-26 23:34:44 UTC
I was unable to find any details at the linked page; there is only a question about something called PICSim.

Could you please list the exact sequence of steps necessary to reproduce the problem?
Comment 2 Jamie Bliss 2004-10-26 23:49:54 UTC
I'm sorry, the pages linked ARE the problem.

To reproduce steps:
1. Go to talk page
2. click move tab
3. Move to another talk page (preferabley one for an article).
Comment 3 Brion Vibber 2004-10-27 08:08:24 UTC
I cannot find any problem following the described actions on 1.4alpha or 1.3 test wikis.

However there does seem to be a problem with your Spec_Talk: namespace; when visiting a Spec_Talk 
page it shows itself as the 'Article' link, and the plain title as the 'Discussion' link. The first part of this may 
be caused by incorrectly using a space instead of an underscore in the $wgExtraNamespaces definition. I'm 
not sure what would cause the second part unless you've hardcoded this somehow; I can't reproduce that 
part on my test wikis.
Comment 4 Jamie Bliss 2004-10-27 21:42:55 UTC
Ah, that's what's up.

I hadn't set $wgExtraNamespaces, though I did set $wgNamespacesWithSubpages, 
$wgNamespacesToBeSearchedDefault, and 2 I probably shouldn't of ($wgNamespaceNamesEn and the 
constants NS_SPEC & NS_SPEC_TALK).

And yes, the behavior Brion described was what was up.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links