Last modified: 2006-09-13 14:40:32 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 7310 - EXIF data for images in Commons contains broken links if another interface language is chosen
EXIF data for images in Commons contains broken links if another interface la...
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
unspecified
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 12:59 UTC by PDD
Modified: 2006-09-13 14:40 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description PDD 2006-09-13 12:59:17 UTC
Depending on the interface language chosen in preferences, Metadata for images
contain inconsistent, partially incorrect links.

Example: If chosen interface language is English, "Camera manufacturer" and
"Camera model" link to the respective articles on en.wikipedia. If, on the other
hand, German is chosen, "Camera model" links nowhere and "Camera manufacturer"
links to a non-existent (and incorrectly named) category "Kategorie:Camera:Canon".
Comment 1 Rotem Liss 2006-09-13 13:02:35 UTC
Please link to an example.
Comment 2 PDD 2006-09-13 14:17:05 UTC
Example: any picture containing Metadata. Here is one uploaded 5 minutes ago:
http://commons.wikimedia.org/wiki/Image:Panthera_tigris_Aus_Zoo_Aug06.JPG
Comment 3 Rotem Liss 2006-09-13 14:24:37 UTC
I think that http://commons.wikimedia.org/wiki/MediaWiki:Exif-make-value/de is
the problem – it should contain an interwiki link, like the three English messages:
* http://commons.wikimedia.org/wiki/MediaWiki:Exif-make-value
* http://commons.wikimedia.org/wiki/MediaWiki:Exif-model-value
* http://commons.wikimedia.org/wiki/MediaWiki:Exif-software-value

It's not a bug in the software.
Comment 4 PDD 2006-09-13 14:29:02 UTC
Yeah, that seems to be it. Maybe even two interwiki links (German and English) as in
* http://commons.wikimedia.org/wiki/MediaWiki:Exif-make-value/sv

It's alocalization bug then. Should these not be eported here?
Comment 5 Rotem Liss 2006-09-13 14:35:23 UTC
Only bugs in the MediaWiki software (or bugs in the extensions, or bugs in
Wikimedia sites *which can be solved only by those with shell access*, like
installing of extensions or changing site settings) should be reported here. The
default MediaWiki package does not contain such interwiki links – they are exist
only in Commons, and created by Commons admins. Therefore, please talk to a
Commons admin to change it.
Comment 6 Raimond Spekking 2006-09-13 14:36:38 UTC
http://commons.wikimedia.org/wiki/MediaWiki:Exif-make-value/de edited. You can
propose these kind of changes in the MediaWiki namespane at
http://commons.wikimedia.org/wiki/Commons:Forum (german) or
http://commons.wikimedia.org/wiki/Commons:Village pump (english)
Comment 7 PDD 2006-09-13 14:40:32 UTC
Thanks a lot.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links