Last modified: 2006-09-07 07:46:52 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 7220 - keep edit summary in spam protection confirmation page
keep edit summary in spam protection confirmation page
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
unspecified
All All
: Normal minor with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-03 14:55 UTC by schosch
Modified: 2006-09-07 07:46 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description schosch 2006-09-03 14:55:09 UTC
Hi there,

(sometimes?, working anonymous) when entering a www-link on a page, a spam
protection confirm page is opened next; that's ok, but all comments, one added
in the "edit summary" are lost when this page opens up; because one doesn't
expect this behavior of the software (deleting the edit summay) one doesn't
notice that and the summary is lost. 

My wish: Is it possible to keep the "edit summary" one enters also in the "spam
protection confirmation page" (whatever this page is called :-)

Greetings, Schusch (and, by the way: thanks for mediawiki :-)
Comment 1 Brion Vibber 2006-09-03 14:56:33 UTC
Have never been able to reproduce this, please be specific about directions to reproduce 
the problem
Comment 2 Rotem Liss 2006-09-03 15:05:16 UTC
I remember that I lost the edit summary once or twice (although I think it
occurred because of the error "the database is locked for editing", it may be
the same problem) when I used a section editing (the default edit summary, of
the link to the section, was restored). I will try to reproduce it later.
Comment 3 schosch 2006-09-03 15:15:07 UTC
Hm, when I add a new www-link as IP and trying to save that, a special page
opens - and asks for entering a code, given in an image. In this page the edit
summary, which I entered in the page before, is lost. That happened to me as
anonymous user in de-WP serveral times. In fact, the edit summary was never kept
to this confirmation page - so as a workaround (now I know it), i go back, copy
my edit summary, go forward and confirm the code. 

I did try it in en-wp some minutes ago, but I missed the confirmation page after
going back (maybe by going back and pressing "save" instead of "forward" from
the browser I got around the confirmation?) - by a second try the confirmation
page didn't appear (confirmation for an ip only once a day, an hour or so?)
Comment 4 schosch 2006-09-03 15:19:30 UTC
problem occured with firefox on linux and windows
Comment 5 Brion Vibber 2006-09-03 15:28:12 UTC
Still cannot reproduce problem on de.wikipedia with Firefox 1.5.0.6 on Mac OS X.

1) While not logged in, visit http://de.wikipedia.org/wiki/Benutzer:Brion_VIBBER/Spamtest
2) click 'Seite bearbeiten' tab

Now at the edit screen:
3) in main box, type 'http://example.com/' (without quotes)
4) in summary box, type 'an edit summary'
5) click "Seite speichern"

At second edit screen, now with the captcha box. I notice that my edit summary is still in the 
summary box.
6) Type the words into the captcha edit box
7) click "Seite speichern"

Now my edit is saved.
8) click 'Versionen/Autoren'

Here I can confirm that my edit summary was indeed saved intact.

Please try to follow these exact directions, or specify the exact directions for you.
Comment 6 schosch 2006-09-03 15:35:20 UTC
ok, I tried out - and find out that the problem applies to section editing (see
version history)
Comment 7 Rotem Liss 2006-09-03 15:47:17 UTC
I succeeded to reproduce the bug in my test wiki, and I'm going to check how to
fix it.
Comment 8 Rotem Liss 2006-09-03 16:02:11 UTC
Fixed in r16372.
Comment 9 schosch 2006-09-07 07:46:52 UTC
Great! A big thanks for eliminating a small but annoying bug :-)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links