Last modified: 2010-05-15 15:28:55 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 718 - Bad charset in cached pages.
Bad charset in cached pages.
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.3.x
PC All
: Normal major with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 23:25 UTC by Vasco Alexandre da Silva Costa
Modified: 2010-05-15 15:28 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Vasco Alexandre da Silva Costa 2004-10-14 23:25:05 UTC
Hello,

I have these variables set in my LocalSettings.php:
$wgLanguageCode = "en";
$wgUseLatin1 = false;

$wgUseFileCache = true;
$wgUseGzip = false;

So my Wiki is in English/UTF-8.

When an anonymous user is fetching pages from the file cache, my browser
(Mozilla Firefox) detects the page charset wrong. It gets the default httpd
charset instead of UTF-8. While a logged in user, not getting his page from the
file cache, will have his browser detect the page charset correctly as UTF-8.

I tried setting:
$wgInputEncoding = "UTF-8";
$wgOutputEncoding = "UTF-8";

It didn't help. I assume the PHP code which sends pages from the file cache does
not send a proper HTTP Header with charset=UTF-8, while the regular uncached
code does.

I have temporarily worked around this via my httpd config, but its a kludge at best.
Comment 1 zhengzhu 2004-10-18 18:24:31 UTC
fixed CacheManager.php in cvs HEAD (v1.11) and REL1_3 (v1.5.2.3) 

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links