Last modified: 2010-05-15 15:41:18 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6852 - the installer loops on trying pointing the user to the config page
the installer loops on trying pointing the user to the config page
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.7.x
Other Linux
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: patch, patch-need-review
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-29 15:57 UTC by Thierry Vignaud
Modified: 2010-05-15 15:41 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
this simple patch fixes the looping (516 bytes, patch)
2006-07-29 15:58 UTC, Thierry Vignaud
Details

Description Thierry Vignaud 2006-07-29 15:57:18 UTC
The installer loops on trying pointing the user to the config 
page. Ie on first access, it points at eg 
localhost/mediawiki/index.php/config/index.php which then 
points to /mediawiki/index.php/config/config/index.php, ...

It's trivial for the user to strip the annoying index.php 
part but it's still annoying for the user.

I suspect this bug doesn't happen on site where "index.php/" 
doesn't appear in URLs.
Comment 1 Thierry Vignaud 2006-07-29 15:58:30 UTC
Created attachment 2169 [details]
this simple patch fixes the looping

It may be wrong for sites where "/index.php/" is not a substring of the URLs
(untested)
Comment 2 Thierry Vignaud 2006-07-29 16:10:23 UTC
ie for sites using http://meta.wikimedia.org/wiki/Rewrite_Rules
Comment 3 Greg Sabino Mullane 2006-07-30 01:54:04 UTC
This looks as though it has already been fixed: please see lines 39-44 of
includes/templates/NoLocalSettings.php in the latest svn version.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links