Last modified: 2008-09-28 03:24:55 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 683 - Intermittent message cache failure
Intermittent message cache failure
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://vi.wikipedia.org/
:
: 2734 6707 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 02:07 UTC by Minh Nguyễn
Modified: 2008-09-28 03:24 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Minh Nguyễn 2004-10-11 02:07:44 UTC
Somewhere between 19:00 and 2:00 UTC, the Vietnamese Wikipedia
(vi.wikipedia.org) switched from using the localized interface (using the
MediaWiki namespace) to using the default English interface.
vi:Special:Allmessages only shows English messages now. :(
Comment 1 Brion Vibber 2004-10-11 02:13:16 UTC
I've forced the message cache to clear ($wgMessageCache->clear() in eval.php) and it seems to be set to rights again.

Not sure what causes this exactly. :(
Comment 2 Carlos 2005-07-04 13:14:18 UTC
Could you please do the same in spanish wikipedia? We are having the same
problem (I think).
Comment 3 River Tarnell 2005-07-07 03:19:45 UTC
i've made a couple of checkins related to this in MessageCache 1.58 and ObjectCache 1.23.   
persistant connections are now disabled because of a bad interaction between memcached-client  
and the object cache:  
  
<innocence> there seems to be an interaction issue between the messagecache and the memcache  
client when a persintan socket fails  
<innocence> the client deletes the socket, then return an error, and the messagecache sees  
the error and sets "error" in the key, but on another server.. because the old host was  
marked as dead  
  
i also replaced the error key into $wgMemcKey.'-status' instead of the key directly, because  
of the following observation:  
  
> > MemCache: sock i:0; got eswiki:messages => Array  
resource(104) of type (persistent stream)  
> > resource(104) of type (persistent stream)  
> > resource(104) of type (persistent stream)  
> > MemCache: sock i:0; got eswiki:messages => loading  
resource(104) of type (persistent stream)  
> > MemCache: sock i:0; got eswiki:messages => Array  
resource(104) of type (persistent stream)  
> > MemCache: sock i:0; got eswiki:messages => error  
resource(104) of type (persistent stream)  
> > MemCache: sock i:0; got eswiki:messages => error  
resource(104) of type (persistent stream)  
  
i.e. the message are correctly loaded, then replaced by an error key.  i don't know why this  
occurs, but this workaround may suffice.  
 
also moving bug to mediawiki. 
Comment 4 Angela 2005-07-07 04:24:18 UTC
*** Bug 2734 has been marked as a duplicate of this bug. ***
Comment 5 Angela 2005-07-07 04:25:05 UTC
This is also happening on sh and lb since 1.5, as the messages below show.

==SH Wikipedia system messages==

Hallo Angela. Can you tell me why sometimes sysetm messages are translated, but
somestames they are not? I translated most important messages here but now
interface is not on Serbocroatian. Can you tell me why, and what I shall do?
Thank you, --Pokrajac 22:00, 5 Jul 2005 (UTC)

==lb-wiki: language swaps of user interface==

Dear Angela,
I contact you in your quality as a developer re a problem that we experience at
the lb-wiki since the first tests with MediaWiki 1.5. started: Whatever language
preference one indicates for the user interface, the user interface randomly
swaps from that preferred language to English and back. Except the fact that of
course the lb-users do not feel very comfortable with these random language
swaps, some of our links not situated in the main namespace do no longer work
and all our bots are currently down as they can not handle random window title
changes.
Can you please help to get this bug fixed or have the present request forwarded
to another competent developer? Thanks. --Otets 6 July 2005 20:39 (UTC)
Comment 6 Brion Vibber 2006-07-16 20:39:50 UTC
*** Bug 6707 has been marked as a duplicate of this bug. ***
Comment 7 Aaron Schulz 2008-09-28 00:46:49 UTC
Is this still an issue?
Comment 8 Minh Nguyễn 2008-09-28 03:09:14 UTC
I haven't seen this anywhere since, so I think we can close the bug now.
Comment 9 Aaron Schulz 2008-09-28 03:24:55 UTC
(In reply to comment #8)
> I haven't seen this anywhere since, so I think we can close the bug now.
> 

Closing...

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links