Last modified: 2006-07-14 05:17:44 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6660 - Potentially missing </textarea> tag when editing non-existent page as blocked user
Potentially missing </textarea> tag when editing non-existent page as blocked...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.8.x
All All
: Low minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-13 04:38 UTC by Nick Jenkins
Modified: 2006-07-14 05:17 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Example of HTML I'm seeing (7.09 KB, text/html)
2006-07-13 04:39 UTC, Nick Jenkins
Details

Description Nick Jenkins 2006-07-13 04:38:04 UTC
After blocking myself on a local test wiki, I tried editing a non-existent page
as a blocked anon. (In this example I went to:
http://192.168.0.64/wiki/index.php?title=XYZW&action=edit )

The HTML returned when trying to do this seems to be missing a tag for closing
the text area. (As a result of this, the second half of the HTML is shown in the
textarea, and the navbar/footer/logo/etc are missing, in both Firefox & IE.)

I'll include the HTML that I'm seeing as an attachment shortly, but basically I
think the HTML seems to need an extra line, such as:
==================================================
  </p><textarea id="wpTextbox1" name="wpTextbox1" cols="80" rows="25"
readonly="readonly">
+ Article does not exist</textarea>
  <div class="printfooter">
==================================================
Comment 1 Nick Jenkins 2006-07-13 04:39:18 UTC
Created attachment 2075 [details]
Example of HTML I'm seeing
Comment 2 Rob Church 2006-07-13 10:07:32 UTC
Should be fixed in SVN trunk, r. As far as I can tell, the problem was due to
wfElement() receiving a blank string under those circumstances, which caused it
to output a single container tag. I've sanitised the behaviour of the edit form
when the page doesn't exist and the user is blocked.

As a further precaution, I've also modified that part of the code to use
wfOpenElement() and wfCloseElement() in an explicit manner, so if I've not
spotted another stupid case, then we should be covered.

[Brion: This one is probably worth backporting to REL1_7]
Comment 3 Rob Church 2006-07-13 10:08:49 UTC
Ack, apologies; that was r15580 and r15581.
Comment 4 Nick Jenkins 2006-07-14 05:17:44 UTC
Thank you once again Rob!

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links