Last modified: 2010-03-22 15:34:40 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6515 - links in timelines break on secure.wikimedia.org
links in timelines break on secure.wikimedia.org
Status: RESOLVED DUPLICATE of bug 21948
Product: MediaWiki extensions
Classification: Unclassified
EasyTimeline (Other open bugs)
unspecified
All All
: Normal major with 1 vote (vote)
: ---
Assigned To: Erik Zachte
https://secure.wikimedia.org/wikipedi...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-02 14:39 UTC by Leung Ki Chi
Modified: 2010-03-22 15:34 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Leung Ki Chi 2006-07-02 14:39:16 UTC
Category links (and possibly other wikilinks) within timelines appear not 
to work when accessing enwiki via secure.wikimedia.org. For example, in 
the URL given, the wikilink for March 2006 [[:Category:Wikify from March 
2006]] in the timeline (under the "Progress" section) translates to a link 
to https://secure.wikimedia.org/wiki/:Category:Wikify_from_March_2006 
which brings up a "wiki does not exist" error. The wikilink to the same 
category under the "subcategory" section works fine.
Comment 1 Siebrand Mazeland 2008-08-13 11:49:25 UTC
Assigned to extension developer.
Comment 2 Happy-melon 2009-10-22 08:49:39 UTC
This affects all links, see eg https://secure.wikimedia.org/wikipedia/en/wiki/Template:ArbitrationCommitteeChartRecent.
Comment 3 Robin Pepermans (SPQRobin) 2010-03-21 20:34:33 UTC
This is true for both directions:
If someone using the normal server edits a timeline, the links only work for the normal server and not for the secure server.
If someone using the secure server edits it, it works for the secure server and no longer for the normal server.
So, the timeline generates the URL based on the last editor.

See e.g. http://incubator.wikimedia.org/wiki/User:MF-Warburg/timelines and http://incubator.wikimedia.org/wiki/Incubator:Test-administrators (MF-Warburg uses the secure server).
Comment 4 Bawolff (Brian Wolff) 2010-03-22 01:38:05 UTC
Unless i'm missing something, I'm pretty sure this was fixed in r60863 by Platonides.

In fact I think this would be a duplicate of  Bug 21948. Marking as such.

*** This bug has been marked as a duplicate of bug 21948 ***
Comment 5 Platonides 2010-03-22 15:34:40 UTC
It was fixed on r60863, but currently extensions at WMF projects are at r57449.

Do note that after it goes live, timelines last edited on secure will need to be purged purge once.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links