Last modified: 2014-03-28 00:31:42 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6250 - PNG replacement image for .SVG does not show transparency gradient correctly
PNG replacement image for .SVG does not show transparency gradient correctly
Status: NEW
Product: Wikimedia
Classification: Unclassified
SVG rendering (Other open bugs)
unspecified
PC Windows XP
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://commons.wikimedia.org/wiki/Ima...
:
Depends on:
Blocks: svg
  Show dependency treegraph
 
Reported: 2006-06-09 13:49 UTC by Rainer Bielefeld
Modified: 2014-03-28 00:31 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Mask with a gradient get lost or disorientated (dependeing on rendering resolution) (27.62 KB, application/xml)
2012-09-21 11:25 UTC, PRO
Details

Description Rainer Bielefeld 2006-06-09 13:49:21 UTC
Under a.m. URL you see
<http://upload.wikimedia.org/wikipedia/commons/thumb/7/74/Rotary_vane_pump_principle_%28System_Willimczik%29.svg/800px-Rotary_vane_pump_principle_%28System_Willimczik%29.svg.png>
which is the replacement for the original .svg

Most of the image looks fine, but at the area "Einlass" the rotation of the blue
transparent area is not correct, and at "Auslass" the transparent red ellipse is
shown as a rectangle.

Image
<http://upload.wikimedia.org/wikipedia/commons/7/74/Rotary_vane_pump_principle_%28System_Willimczik%29.svg>
will be shown without that problem in Seamonkey-browser and IE6

You can see how it should look correctla at the old .png version
<http://de.wikipedia.org/wiki/Bild:DrehschieberNachWolfhart.jpg>
Comment 1 Brion Vibber 2009-08-03 16:53:45 UTC
Assigning SVG bugs to Ariel -- need a cleanup pass to see what's fixed up by a librsvg upgrade, what can be resolved with fixes to our font configuration, what can be fixed on our end, and what still needs to be pushed upstream.
Comment 2 Ariel T. Glenn 2011-09-18 09:52:48 UTC
giving SVG bugs back to the pool.
Comment 3 Derk-Jan Hartman 2011-12-04 22:17:38 UTC
Issue still exists after recent librsvg update
Comment 4 Brion Vibber 2011-12-04 22:30:16 UTC
Looks like two major problems:

* mask is not applied to those blue and red gradient areas
* text is positioned incorrectly
Comment 5 PRO 2012-09-21 08:17:06 UTC
(In reply to comment #3)
> Issue still exists after recent librsvg update

Here is a real example for a mask with gradient doesn't work. But this seems dependent on resolution: http://upload.wikimedia.org/wikipedia/de/thumb/archive/4/45/20120920225516!Ziehl_logo2.svg/500px-Ziehl_logo2.svg.png

near correctly at resolution 300px: http://upload.wikimedia.org/wikipedia/de/thumb/archive/4/45/20120920225516!Ziehl_logo2.svg/300px-Ziehl_logo2.svg.png

It seems also that the gradient from the mask shifts, with higher resolution, maybe this is the reason.

SVG not rendered (should look correctly): 
http://upload.wikimedia.org/wikipedia/de/archive/4/45/20120920225516!Ziehl_logo2.svg

Hint: the version from 	21. Sep. 2012 is "fixed" by replacing/removing the mask with color gradient. clipPath is indeed involved here, but seems to have no causal involvement.(In reply to comment #3)
> Issue still exists after recent librsvg update
Comment 6 PRO 2012-09-21 10:40:08 UTC
(In reply to comment #3)
> Issue still exists after recent librsvg update

Here is a real example for a mask with gradient doesn't work. But this seems dependent on resolution: http://upload.wikimedia.org/wikipedia/de/thumb/archive/4/45/20120920225516!Ziehl_logo2.svg/500px-Ziehl_logo2.svg.png

near correctly at resolution 300px: http://upload.wikimedia.org/wikipedia/de/thumb/archive/4/45/20120920225516!Ziehl_logo2.svg/300px-Ziehl_logo2.svg.png

It seems also that the gradient from the mask shifts, with higher resolution, maybe this is the reason.

SVG not rendered (should look correctly): 
http://upload.wikimedia.org/wikipedia/de/archive/4/45/20120920225516!Ziehl_logo2.svg

Hint: the version from 	21. Sep. 2012 is "fixed" by replacing/removing the mask with color gradient. clipPath is indeed involved here, but seems to have no causal involvement. There are also some inconsistents with cloned gradients with gradientTransform in browser and SVG-editors

(In reply to comment #3)
> Issue still exists after recent librsvg update
Comment 7 PRO 2012-09-21 11:25:40 UTC
Created attachment 11134 [details]
Mask with a gradient get lost or disorientated (dependeing on rendering resolution)

The purple gradient disappear also in some cases.
Comment 8 PRO 2012-09-21 11:32:00 UTC
The attachment from me can be deleted, it is here: http://commons.wikimedia.org/wiki/File:SVG_mask_gradient_bug.svg
Comment 9 Bawolff (Brian Wolff) 2014-03-28 00:31:42 UTC
(In reply to PRO from comment #8)
> The attachment from me can be deleted, it is here:
> http://commons.wikimedia.org/wiki/File:SVG_mask_gradient_bug.svg

We generally dont delete attachments unless there is specific reason to (e.g. privacy concerns)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links