Last modified: 2006-06-20 13:20:16 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6189 - Show an error to an unprivilleged user trying to create account
Show an error to an unprivilleged user trying to create account
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
User login and signup (Other open bugs)
unspecified
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-03 13:37 UTC by Rotem Liss
Modified: 2006-06-20 13:20 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Patch (trunk) (1.49 KB, patch)
2006-06-03 13:37 UTC, Rotem Liss
Details

Description Rotem Liss 2006-06-03 13:37:31 UTC
1. Set $wgGroupPermissions["*"]["createaccount"] = false.
2. Log out.
3. Go to the accout creation page.

Expected results:
An error is shown.

Actual results:
Only the "emailforlost" message is shown. However, if the user sends the
parameters to the create account page (with action=submit) in another way, he
gets the error message.

Cause:
The error message is shown only when the account is created, not in the form.
Also, the template checks for the data 'create' (which checks if the user is
allowed to create account), and hides most of the account creation form when it
is false. However, we should display an error message.

Fix:
Delete the check for 'create' in the data, and delete 'create' itself which is
unused, then really check (before the form) if the user is allowed to create
account, and show an error message if not.
Comment 1 Rotem Liss 2006-06-03 13:37:58 UTC
Created attachment 1892 [details]
Patch (trunk)
Comment 2 Rotem Liss 2006-06-20 13:20:16 UTC
Commited to r14840.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links