Last modified: 2006-05-25 08:22:43 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6062 - Logic error in {{BASEPAGENAME}}
Logic error in {{BASEPAGENAME}}
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/w/index.php?t...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 00:01 UTC by emddudley
Modified: 2006-05-25 08:22 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description emddudley 2006-05-24 00:01:02 UTC
{{BASEPAGENAME}} does not work when viewing an old version of a page, such as in
the provided URL. In the {{talkarchive}} template, there should be a link to the
current talk page instead of the text "[[User_talk:|current talk page]]".
Comment 1 emddudley 2006-05-24 21:48:18 UTC
The link at the top of the provided URL has been removed pending this bug's
resolution. I found the bug using:

[[{{{1|{{TALKSPACE}}:{{BASEPAGENAME}}}}}|current talk page]]

Normally, it returns something like "[[User_talk:Mdd4696|current talk page]]",
but when viewing old revisions, it returns "[[User_talk:|current talk page]]".
Comment 2 Rob Church 2006-05-25 08:22:43 UTC
Actually, the problem I found was a more generic one; a logic error caused the
last part of the title, after /, to be discarded...if there was no / in the
first place, the entire title was discarded. Oops.

Fixed in SVN trunk, r14376.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links