Last modified: 2010-05-15 15:56:51 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6060 - Upgrading from MW 1.6.5 to 1.6.6 totally overwrites the MediaWiki namespace
Upgrading from MW 1.6.5 to 1.6.6 totally overwrites the MediaWiki namespace
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.6.x
PC Linux
: High critical (vote)
: ---
Assigned To: Brion Vibber
http://www.manuel-charisius.de/valarea/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 19:35 UTC by Manuel
Modified: 2010-05-15 15:56 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Manuel 2006-05-23 19:35:45 UTC
(Note: In the Component selection of the bug filing form, there's no "Upgrading"
section, so I chose "Installation". Also, 1.6.6 is not yet listed in the Version
selection.)

I tried to upgrade from MediaWiki 1.6.5 to 1.6.6 but in the end had to go back
to 1.6.5 because after upgrading, my MediaWiki namespace (within which I had
modified most of the system messages in order to customize the text of my Wiki)
had totally reverted back to the defaults.

The first upgrade attempt involved using the update.php script in the
maintenance directory.
In the second attempt (after I had gone back to 1.6.5), I deleted
LocalSettings.php and re-run the web installer.
There was no difference whatsoever.

* MediaWiki: 1.6.5 (the bug itself seems to be in 1.6.6, though)
* PHP: 4.4.2 (apache)
* MySQL: 4.0.24_Debian-10sarge1 
* Wiki language: German

On the developer's IRC channel, I learned that this behaviour of the update
script isn't normal, which matches my previous experience (I upgraded from 1.6.3
to 1.6.5 only weeks ago, and the MediaWiki namespace was left untouched by the
process).

Thanks for your help!
-Manuel
Comment 1 Brion Vibber 2006-05-23 19:58:57 UTC
Unable to reproduce upgrading from 1.6.3 to 1.6.6 with 
update.php.

Can you please provide some more detailed examples, such as a 
list of message pages which were reverted, exactly how they 
changed, and what appears in the history for them?
Comment 2 Manuel 2006-05-23 20:45:54 UTC
Perhaps the bug only occurs when upgrading from 1.6.5 to 1.6.6, as I've
described above, not 1.6.3 to 1.6.6?

Anyway, have a look at
http://www.manuel-charisius.de/valarea/index.php/Spezial:Allmessages
You can see the system messages I changed.

Grey = no change was made
Red = message as provided in the language files
Green = my new version, created by editing this specific message, e. g.
http://www.manuel-charisius.de/valarea/index.php/MediaWiki:1movedto2

After upgrading to 1.6.6, all these changes were lost. The Special:Allmessages
(or Spezial:Allmessages in wikis with the language set to German) page looked as
though I had freshly installed a MediaWiki 1.6.6 - everything was grey again.

I noticed this at all because the sidebar had reverted to the default after I
had upgraded (showing again the "donate" link, for example). As the sidebar is
part of the "Allmessages", my changes made there "Autoren-Website", "Weblog",
"Impressum", etc.) were gone.

I then checked the "Allmessages" and, after realising my changes were gone,
deduced that it had been the whole MediaWiki namespace (nothing more, nothing
less) that had been reset.
Comment 3 Brion Vibber 2006-05-23 21:03:29 UTC
Did you:
1) Check the content message pages to confirm that things were 
missing or overwritten?

2) Try clearing the objectcache table (or memcached etc if using 
those) to regenerate the message cache?

I can see at the URL you provide that the message page exists as 
edited by you on April 30, so it doesn't appear to have been 
overwritten.
Comment 4 Manuel 2006-05-23 21:16:54 UTC
Well, as I said, I went back to 1.6.5 (meaning: I restored the pages and the
database to its state prior to today's upgrade attempts). So what you now see is
completely unaffected by the problem.

1) No. I put my trust in the "Allmessages" overview. But the navigation bar was
confirmation enough, since my own links were gone and replaced by the default ones.

2) No. I'm not using memcache. But I might try clearing the objectcache table.

BTW, I just tried to reproduce the bug on a virtual webserver (XAMPP 1.5.1 Linux
with PHP 4.4.1 and MySQL 5.0.18) and failed. If nothing else works, I might just
try and copy the local database to the Debian system as a workaround ...
Comment 5 Brion Vibber 2006-05-23 22:15:00 UTC
Both items in 1) would have come from the message cache. Please 
check the actual page contents and edit history.
Comment 6 Manuel 2006-05-24 09:21:27 UTC
Hi Brion,

I just tried again today - and now, everything seems to work fine. No idea what
went wrong yesterday. ;-(

Anyway, thanks a lot for your help. You might mark this bug as invalid now
(unless anybody else starts to complain, which I hope not, of course. ;-)

-Manuel
Comment 7 Manuel 2006-05-24 09:50:57 UTC
Me again. I think I know what happened, and for developers as well as other
users it may be worth noting:

After upgrading from my initial installation (1.6.3) to 1.6.5, I ran the
following two maintenance scripts:

php deleteOldRevisions.php
and
php rebuildrecentchanges.php

in order to clear out the huge revision history that had accumulated not only in
the MediaWiki namespace, but within normal articles as well.

Now here's the crucial point: Up to the moment I upgraded to 1.6.6, I made no
more changes to the MediaWiki namespace / system messages!

So when I upgraded, the update script had to assume I hadn't changed the MW
namespace at all, and therefore re-initialised it.

Last night, however, after I had restored my backed-up files and database and
thus gone back to 1.6.5, I made a few small changes to the MediaWiki namespace.

And when I upgraded today - voilà: everything worked. :)

So the question whether this is a bug or not is not easily answered. As a
temporary workaround, I strongly encourage users who've changed a lot in the MW
namespace and cleared their revision history to change at least one small thing
in the MW namespace BEFORE upgrading.

Hope this helps, and thank you, Brion, for your support.
-Manuel

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links