Last modified: 2006-05-28 21:59:41 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6040 - "Show Changes" doesn't run pre-save transform (subst, tilde)
"Show Changes" doesn't run pre-save transform (subst, tilde)
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
1.7.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-21 23:10 UTC by Brion Vibber
Modified: 2006-05-28 21:59 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Brion Vibber 2006-05-21 23:10:05 UTC
Tilde and subst templates appear as raw code on the right-hand side 
when doing "Show Changes" in the editor.

To behave consistently, the pre-save transform should be run on the 
input text before it's sent to the differ, just as we do for preview 
text.
Comment 1 Rob Church 2006-05-28 21:59:41 UTC
Fixed in SVN trunk, r14446.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links