Last modified: 2007-06-08 00:59:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6005 - Warn user when email confirmation is pending
Warn user when email confirmation is pending
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Special:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 15:51 UTC by Fred T. Hamster
Modified: 2007-06-08 00:59 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Fred T. Hamster 2006-05-17 15:51:04 UTC
i requested to confirm my new account's email address.  i got the confirmation
letter, but when i clicked on the enclosed link, i was taken to a mostly blank
page with the error message:

  Confirm E-mail address
  From Wikipedia, the free encyclopedia
  Jump to: navigation, search

  confirmemail_invalid

the page URL was:
  http://en.wikipedia.org/wiki/Special:Confirmemail/b9b26fa19f20d03b6a01580c7712b73a

this happened to me twice, so i decided to report it.
is it possible that the email is sent before the user is actually added to the
user database?  a third time worked and allowed me to confirm my email address.
Comment 1 Rob Church 2006-05-17 16:01:36 UTC
I've fixed the bug (message name spat out, not content)...but the fact it shows
up suggests that the confirmation code wasn't registering. Could be lag if it
comes off a slave.
Comment 2 Brion Vibber 2006-05-17 18:15:40 UTC
1) Was this the only confirmation mail you received, or did you receive multiple?
2) Did you simply take the confirmation mail sent when you registered, or did you 
request a second one through preferences?
3) Was this the complete link in the mail, or was part of the code on a second line?

I can confirm there is no account on the wiki with that code now; this indicates 
that you requested another confirmation after this one.
Comment 3 Fred T. Hamster 2006-05-17 19:00:16 UTC
regarding brion's questions:
1) i received one confirmation, then tried to confirm it, and got the error.  at
that point, i tried again.  the second attempt failed also.  the third try
worked, although i don't actually remember hitting the confirm button a third
time.  but i probably did.

2) my account was set up, but not confirmed.  i clicked confirm on the settings
page.  if there was supposed to be an initial automatic email confirmation, that
did not seem to happen.  but it would explain the third email confirmation.  it
actually seems more likely to me now that i requested a confirmation letter
because i didn't know that one would automatically be generated.  then the
ordering of answering the wrong emails could have caused this problem.

3) the link was complete; it wasn't an issue with multiple line links or spaces
in the middle.

is it possible that the email status could say "confirmation pending" rather
than just "not confirmed"?  if there's an automatic email confirmation process,
i wasn't aware of it and didn't see anything in the interface to alert me to that.
Comment 4 Brion Vibber 2006-05-17 21:10:06 UTC
Yes, that would make sense. Will try to make that happen...
Comment 5 Rob Church 2007-06-08 00:59:37 UTC
Brion fixed this back in r18320.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links