Last modified: 2009-12-30 19:04:23 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 5994 - PNG thumbnails with 64bit depth and transparency display broken
PNG thumbnails with 64bit depth and transparency display broken
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
unspecified
PC All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 05:29 UTC by Cameron Garnham
Modified: 2009-12-30 19:04 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Original hi-res image (54.42 KB, image/png)
2006-05-17 05:31 UTC, Cameron Garnham
Details
250px thumbnail of image (28.74 KB, image/png)
2006-05-17 05:31 UTC, Cameron Garnham
Details
Hi-res image converted to 8 bits/color using pngcrush (21.06 KB, image/png)
2006-05-17 08:37 UTC, Ilmari Karonen
Details
250px thumbnail of converted image (29.53 KB, image/png)
2006-05-17 08:38 UTC, Ilmari Karonen
Details

Description Cameron Garnham 2006-05-17 05:29:22 UTC
The thumbnails to Image:Redox_Reminder.png on wikipage Redox turns out broken. 
The error most probably is caused by the conversion from a 64bit depth to an
32bit one.
Comment 1 Cameron Garnham 2006-05-17 05:31:11 UTC
Created attachment 1763 [details]
Original hi-res image
Comment 2 Cameron Garnham 2006-05-17 05:31:54 UTC
Created attachment 1764 [details]
250px thumbnail of image
Comment 3 Ilmari Karonen 2006-05-17 08:35:28 UTC
Nope, I just converted the image to 8 bits/channel and it's still broken. 
Something else is wrong here.
Comment 4 Ilmari Karonen 2006-05-17 08:37:09 UTC
Created attachment 1765 [details]
Hi-res image converted to 8 bits/color using pngcrush
Comment 5 Ilmari Karonen 2006-05-17 08:38:29 UTC
Created attachment 1766 [details]
250px thumbnail of converted image
Comment 6 Ilmari Karonen 2006-05-17 08:45:05 UTC
Resaving in GIMP fixed the issue.  I suspect it may have been related to the
interlacing in the original image.
Comment 7 Cameron Garnham 2006-05-17 08:58:46 UTC
The Original Image was made with Photoshop CS2
Comment 8 Antoine "hashar" Musso (WMF) 2006-05-20 08:13:13 UTC
If it is a bug in a third party software, maybe we can close it ?
Comment 9 Cameron Garnham 2006-05-20 08:20:23 UTC
No the bug is that MediaWiki dose not have full support for PNG images
Comment 10 emddudley 2006-05-24 00:16:24 UTC
I'm pretty sure MediaWiki has nothing to do with this... ImageMagick and your
browser do all of the work.
Comment 11 Guillaume Paumier 2009-12-30 19:04:23 UTC
Closing as invalid since the problem doesn't seem to come from MediaWiki. Feel free to reopen if you encounter a similar issue.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links