Last modified: 2010-05-15 15:33:13 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T2578, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 578 - rename $wgDisableUploads into $wgEnableUploads (all modules)
rename $wgDisableUploads into $wgEnableUploads (all modules)
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
All All
: Low trivial (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
Blocks: code_quality 1977
  Show dependency treegraph
Reported: 2004-09-26 07:55 UTC by T. Gries
Modified: 2010-05-15 15:33 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description T. Gries 2004-09-26 07:55:21 UTC
As a small request: everytime I install a new wiki, I need to think twice about
the meaning, wheter I have to uncomment
 # $wgDisableUploads = false;

This double negation is logically clear, but more difficult to understand than
the following:

I propose to globally change the name and use of the variable to a positive
meaning, which is disabled if "false" or not defined, the DefaultSettings.php
and LocalSetting would simply contain

 $wgEnableUploads = true;

This can be understood more easily (at least by)
Tom aka Nyxos
Comment 1 Antoine "hashar" Musso (WMF) 2005-01-11 18:19:36 UTC
I believe it is somehow unclear to get people think twice about
enabling it ! :)
Comment 2 Ævar Arnfjörð Bjarmason 2005-03-27 10:39:08 UTC
how about $wgUpload(s) = true/false?
Comment 3 Ævar Arnfjörð Bjarmason 2005-04-01 19:56:06 UTC
Fixed in HEAD

Note You need to log in before you can comment on or make changes to this bug.