Last modified: 2014-02-17 13:38:10 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 5625 - Failed to parse (unknown error) with math due to SELinux
Failed to parse (unknown error) with math due to SELinux
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.6.x
PC Linux
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://hood.eas.asu.edu/che211/wiki
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-17 17:14 UTC by Jeff Heys
Modified: 2014-02-17 13:38 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jeff Heys 2006-04-17 17:14:15 UTC
I am unable to get the math package to work, even after extensive efforts. 
Here's what I've tried:
(1) compiled and tested texvc system -- it works fine from the command line
(2) ensured that dvips, convert, and latex were in the default path -- I even
added the path to those commands in render.ml as a test to see if it would help
-- it did not.
(3) ensured that all necessary subdirectories existed and were owned by "apache".
(4) edited LocalSetting.php to assign the variables correctly
(4) I tried commenting out the commands to remove temporary files in render.ml
to see if I could find where the process was getting stuck.  Apparently, none of
the temporary files are being created.

Despite following the instructions as precisely as possible, testing three
different versions of mediawiki, and googling extensively, I still get the error
"Failed to parse (unknown error)" for even the simplest equation.  I know this
probably isn't enough information to solve my problem, but any test suggestions
that may help me figure out what is going wrong would be greatly, greatly
appreciated.
Comment 1 Brion Vibber 2006-04-17 21:22:15 UTC
Please look at your apache error log.
Comment 2 Jeff Heys 2006-04-18 17:18:49 UTC
The error log contains:

sh: /var/www/html/che211/wiki/math/texvc: Permission denied

I've verified that all users have permission to access this file, and it is
owned by apache.  However, I still get the permission denied error for some
reason.  It is clearly a problem with my php/apache settings and not mediawiki.
 Any suggestions are greatly appreciated.  I've googled but found nothing yet.

- Jeff
Comment 3 Jeff Heys 2006-04-18 23:19:11 UTC
Finally solved this.....I'm using Redhat Enterprise Linux 4.  I was using
SELinux, and the problem was the SELinux Policy.  Selecting "Disable SELinux
protection for httpd daemon" I got everything to work.   

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links