Last modified: 2008-12-13 02:41:56 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 5506 - Linker::formatComment() needs to check for image existence in shared repositories
Linker::formatComment() needs to check for image existence in shared reposito...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
unspecified
All All
: Normal normal with 7 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
http://fr.wikipedia.org/w/index.php?t...
: crosswiki, patch, patch-need-review
: 6405 12813 15437 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 20:03 UTC by Rémi Kaupp
Modified: 2008-12-13 02:41 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Rémi Kaupp 2006-04-08 20:03:33 UTC
When including a link to an image located on Wikimedia Commons in an edit summary, this 
link shows up in red in the page history. However, links to those images are blue if 
included in the page (see URL provided). Links in page history should be blue as well so 
that image page is not in edit mode when clicking on it.
Comment 1 Christopher Beland 2006-04-29 22:14:02 UTC
Red links also occur on the "image" link from the image's discussion page, and
instead of going to the image description page, go to the edit form for the
(empty) image description page.
Comment 2 Brion Vibber 2006-06-22 15:34:50 UTC
*** Bug 6405 has been marked as a duplicate of this bug. ***
Comment 3 Mormegil 2006-06-23 09:31:28 UTC
Oops… three attempts to find this bug and I fail and create a dupe… :-x

Anyway, please note that there is a patch (hopefully) fixing this bug (well, its
edit comment part) attached to bug 6405.
Comment 4 Mormegil 2006-07-05 15:14:40 UTC
Marking +need-review, patch (the patch is attached to bug 6405, not copying it
here).
Comment 5 freakofnurture 2006-12-19 02:45:12 UTC
hopefully fixing this will also fix the "ifexist" parser 
function, e.g.:

{{#ifexist:Image:Some_shared_upload.fmt}} should return true

realistically, this is probably a separate issue altogether?
Comment 6 Rob Church 2006-12-19 11:48:19 UTC
(In reply to comment #5)
> {{#ifexist:Image:Some_shared_upload.fmt}} should return true

It was a separate issue, and it was addressed in a different manner; you want
the syntax

{{#ifexist:Media:Some_shared_upload.png}}
Comment 7 Ilmari Karonen 2008-12-13 02:41:14 UTC
Fixed in r44520.
Comment 8 Ilmari Karonen 2008-12-13 02:41:42 UTC
*** Bug 15437 has been marked as a duplicate of this bug. ***
Comment 9 Ilmari Karonen 2008-12-13 02:41:56 UTC
*** Bug 12813 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links