Last modified: 2006-02-22 21:27:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T2546, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 546 - Search engines do not index some pages
Search engines do not index some pages
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
All All
: Normal major with 3 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2004-09-21 13:52 UTC by Leah
Modified: 2006-02-22 21:27 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Leah 2004-09-21 13:52:35 UTC
This makes it very difficult to find some specific discussions when full-text
search is disabled.  It may be that many talk pages are "orphaned" from Google's
perspective, and will never be found during a regular crawl of the website.  For
example, searching for "Discussions about the MediaWiki namespace" produces two
results only, ''on a mirror''.
Comment 1 Steven Hilton 2005-07-17 02:55:15 UTC
I am having this problem as well. 

I was running 1.4 and a few days ago I upgraded to 1.5beta3.  I ran the two
commandline php upgrade scripts in order --  upgrade1_5.php update.php.

The upgrade seemed to have been completely transparent and successful. Then late
friday afternoon (it's always a late friday afternoon, isn't it?), people began
to notice that searching wasn't working.

I'm not that familiar with mediawiki's internals yet, but I think I narrowed it
down to this:

Search works, but new articles created since the upgrade are not getting into
the index. I even dropped and rebuilt in search index (with
rebuildtextindex.php) hoping that would fix it, but I still get the same results
-- only content created while still running the 1.4 version is showing up in the
search results even after a rebuild.

I *think*, but am not really not sure, that it has something to with how stuff
gets into the index. The index update is triggered by data in the
'recentchanges' table? The updateSearchIndex.php script seems to select against
the recentchanges table to find out what to put in the search index. 

In trying to track in down further, I found that running the
'rebuildrecentchanges.php' script dies with this error:

 php rebuildrecentchanges.php
Loading from CUR table...
Loading from OLD table...
A database error has occurred
Query: INSERT INTO `recentchanges`
FROM `old`,`cur` WHERE old_namespace=cur_namespace AND old_title=cur_title ORDER
BY old_timestamp DESC LIMIT 5000
Error: 1146 Table 'midev_wiki_db.old' doesn't exist

That is correct, the 'old' table does not exist in my schema. Further, when I
ran the script, *I lost all of the recent changes data made since the upgrade.*
 The content and history of individual articles was not lost, and new edits do
still go into the recentchanges table.  But I'm afraid I just lost several days
of recent changes data by running a maintenance script.

I will continue to investigate as time allows.

Note You need to log in before you can comment on or make changes to this bug.