Last modified: 2008-08-11 16:21:55 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 5429 - Problem when I include more than one special page
Problem when I include more than one special page
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
PC Windows XP
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://www.ecrivez.cliranet.com/wikim...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 16:08 UTC by Laurent
Modified: 2008-08-11 16:21 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Laurent 2006-04-02 16:08:02 UTC
I have wrote some special extension for my wiki and i have a problem.
If I include only one of my special extension, all works.
But if I include 2 special page, only the second appears.
And if I include more than 3 special page, the first isn't include, the second
appears normally, and the other aren't normally. 

See youself the 3 example here :
http://www.ecrivez.cliranet.com/wikimusique/index.php/Bug

Thanks for your help.

(sorry my english was so bad)
Comment 1 Laurent 2006-04-04 19:43:04 UTC
I have fixed the first problem by removing at line 2334 in parser.php :
$text = "\n\n" . $this->insertStripItem( $text, $this->mStripState );

It's not a solution.

The second problem is always here. The included text don't appear normally. Like
if it is in a <pre> tag (see it here :
http://www.ecrivez.cliranet.com/wikimusique/index.php/Example_3).
Comment 2 Siebrand Mazeland 2008-08-11 16:21:55 UTC
RESOLVED (unknown when). The below code block processes just fine. Sample URLs are no longer available.

{{Special:Newimages}}
{{Special:Allpages}}

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links