Last modified: 2010-05-15 15:38:33 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 5255 - Templates in <nowiki> included on the Copyrightwarning special page
Templates in <nowiki> included on the Copyrightwarning special page
Status: RESOLVED DUPLICATE of bug 5656
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
1.5.x
All All
: Normal normal with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-15 05:36 UTC by Beauxcphus
Modified: 2010-05-15 15:38 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Beauxcphus 2006-03-15 05:36:08 UTC
I have a custom Copyrightwarning special page that includes some edittools-like features.  one of the clickables is a template 
like so:

<charinsert><nowiki>{{Subst:TemplateName}}</nowiki></charinsert>

when i view the special page on its own - it looks fine, the wiki is not parsed out.
When i view the edit page, it too looks and works fine.

BUT - the next item doesn not work fine

<charinsert><nowiki>{{TemplateName}}</nowiki></charinsert>

this looks fine when i view the special page on its own - the wiki is not parsed out.
BUT when i view an edit page - the template is parsed and included down by the copyright warning.

this bug is not dependant on the charinsert extension.
Comment 1 Melancholie 2006-03-15 21:43:53 UTC
@Beauxcphus: As long as this bug isn't fixed, you can bypass that problem by
using the following syntax:
<charinsert>{<nowiki>{TemplateName}</nowiki>}</charinsert>
Comment 2 Beauxcphus 2006-03-16 05:05:15 UTC
great idea - thanks!
Comment 3 Brion Vibber 2006-04-28 09:35:35 UTC

*** This bug has been marked as a duplicate of 5656 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links