Last modified: 2012-02-21 11:12:18 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 5163 - Some SVGs render incorrectly
Some SVGs render incorrectly
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
SVG rendering (Other open bugs)
unspecified
PC Windows XP
: Normal normal with 4 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 12274 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-04 12:57 UTC by GeeKaa
Modified: 2012-02-21 11:12 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description GeeKaa 2006-03-04 12:57:12 UTC
Those two images should look the same (was the same file) though, i see a small
difference, in the second file the dots on de dimensionline z.on en z.bo are
missing... Bug in the mediawiki software?
[http://nl.wikipedia.org/wiki/Afbeelding:DoorsnedeGrootheden.svg One]
[http://commons.wikimedia.org/wiki/Image:DoorsnedeGrootheden.svg Two] greetings,
Comment 1 Brion Vibber 2006-03-04 18:23:09 UTC
Old rendering, and you didn't try purging it.
Comment 2 Daniel Kinzler 2006-03-04 19:46:55 UTC
reopening... when I try either image with a new size, I get a broken rendering
(no dots at the end of thin links, no arrows at top and right end of dotted
lines). To me, the "old" rendering at the nl wp looks good... Firefox also
renders it OK for me.
Comment 3 Brion Vibber 2006-03-04 21:15:20 UTC
So the bug isn't that they're different from each other, it's that the rendering 
is incorrect? Can you provide details of the expected rendering?
Comment 4 Daniel Kinzler 2006-03-05 10:31:38 UTC
A screenshot of the image as rendered by firefox:
http://area23.brightbyte.de/svg-bug.png

Note the dots in the vertical lign at the left, and the arrows at the top and
right ends of the dotted lines.
Comment 6 Daniel Kinzler 2006-03-07 09:37:31 UTC
Thanks brion! 

On a unrelated note: maybe it would be nice to have a "upstream issue" status in
bugzilla, indicating MW-devs can't do anything about it, but the bug is not
closed and may require upgrading something at some point to be really fixed. 
Comment 7 GeeKaa 2006-03-07 09:40:59 UTC
Yes, thank you, 2
Comment 8 Shinjiman 2006-04-29 07:41:33 UTC
I think like this graph,
http://commons.wikimedia.org/wiki/Image:Chromosom.svg
maybe got the same problem regarding this bug.
Comment 9 Stéphane Brunner 2007-02-19 13:41:58 UTC
On this image I have as a problem with arrow they are really small, in Firefox
or in Inkscape the arrows will be really bigger !!!

Is it the same bug, is there a work around ?
Comment 10 Stéphane Brunner 2007-02-20 07:17:54 UTC
This image => (http://commons.wikimedia.org/wiki/Image:Compression_JPEG.svg) !
Comment 11 Peter Halasz 2007-02-21 01:27:36 UTC
I've fixed the image by converting the strokes (arrows) to paths (using
Inkscape). However, while this particular image is fixed, the bug is still relevant.
Comment 12 Stéphane Brunner 2007-02-21 07:24:44 UTC
Thanks ;-)
Comment 13 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-05-21 16:25:13 UTC
Upstream issue.  Go vote for the appropriate bugs on the GNOME bug-tracker.
Comment 14 Tim Starling 2007-12-12 05:24:16 UTC
Please leave upstream issues open. 
Comment 15 Tim Starling 2007-12-12 05:25:43 UTC
*** Bug 12274 has been marked as a duplicate of this bug. ***
Comment 16 Kyungjoon Lee 2008-08-11 09:26:36 UTC
Bump. Upstream (librsvg 2.22.2-2 on Debian) renderer seems to work as expected.
Comment 17 Tim Starling 2008-10-14 04:39:44 UTC
Fixed now that we have upgraded to librsvg 2.22.0. 

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links