Last modified: 2006-02-21 20:03:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 5042 - Special:Whatlinkshere does not show links in <ref>
Special:Whatlinkshere does not show links in <ref>
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
Cite (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://fr.wikipedia.org/wiki/Utilisat...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-19 15:16 UTC by Rémi Kaupp
Modified: 2006-02-21 20:03 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Rémi Kaupp 2006-02-19 15:16:42 UTC
When a link is included in a <ref>, the originating article is not included in
the backlinks of the destination article. This is especially problematic on
fr.wikipedia as pages in the Référence: namespace ought to show articles linking
to them.

Have a loook at : 
* Page with <ref> : http://fr.wikipedia.org/wiki/Utilisateur:Korrigan/Brouillon2
* Page linked : http://fr.wikipedia.org/wiki/Référence:Bulk_Carrier_Register
* Backlinks :
http://fr.wikipedia.org/wiki/Special:Whatlinkshere/Référence:Bulk_Carrier_Register

Touching pages or purging cache does not seem to have any effect.
Comment 1 Brion Vibber 2006-02-19 22:05:39 UTC
Confirmed.

Most likely the extension's parser instance isn't passing links
back up to the parent parser.
Comment 2 Brion Vibber 2006-02-21 20:03:07 UTC
extension/Cite/Cite.php had been using its own Parser instance due
to some prior bugs with extension handling and the unique index.
(Avar is unable provide details of this.)

These bugs appear to no longer be present, as far as I can tell.
But who knows, with no bug report and no test case.

I've changed it to make use of the calling Parser instance, and it
now saves the links properly where one might expect.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links