Last modified: 2006-03-01 01:33:20 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 4593 - Rendering problem with SVG engine
Rendering problem with SVG engine
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
PC Linux
: Normal normal with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
http://commons.wikimedia.org/wiki/Ima...
:
Depends on: 4976
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-13 10:20 UTC by Francois
Modified: 2006-03-01 01:33 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Francois 2006-01-13 10:20:08 UTC
I'm stuck with wrong SVG rendering.
Works fine with Inkscape, Firefox or ImageMagic(without transparency).
Here we got black surfaces instead of white original ones. (inverted colors)
Comment 1 Francois 2006-01-29 21:35:52 UTC
I don't know if it comes from the current installed version of Batik, 
but I tried version 1.6 (direct call) and it gives gives me correct rendering.
 
Comment 2 Daniel Kinzler 2006-01-29 21:37:38 UTC
On WikiMedia servers, rsvg is used for rendering
Comment 3 Francois 2006-01-29 21:44:35 UTC
So it may be a problem from this lib.
Can anyone test with installed version on command line (rsvg/rsvg-view)?
I've tested with my rsvg (version 2.8.1) it's worst :(
Comment 4 Francois 2006-01-29 21:51:55 UTC
Rendering with rsvg version 2.12.7 works perfectly.
Comment 5 ejsanders 2006-02-14 03:01:45 UTC
Also having problems with some gradients. Compare
http://commons.wikimedia.org/wiki/Image:Compass.svg with how it should be:
http://commons.wikimedia.org/wiki/Image:Compass.png . 
Comment 6 Brion Vibber 2006-02-28 21:20:26 UTC
Now renders correctly.

OLD RENDERINGS HAVE NOT ALL BEEN REBUILT YET.
TEST WITH NEW SIZES BEFORE COMMENTING FURTHER.
Comment 7 Brion Vibber 2006-03-01 01:33:20 UTC
Ok, action=purge can now be used on an image page to force images to rerender.
(Be careful about caching; make sure it reloads the new image!)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links